aboutsummaryrefslogtreecommitdiffstats
path: root/games/warmux/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/warmux/Makefile')
-rw-r--r--games/warmux/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/games/warmux/Makefile b/games/warmux/Makefile
index a15c193a2ff4..3db9192286f3 100644
--- a/games/warmux/Makefile
+++ b/games/warmux/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: wormux
-# Date created: Thu Dec 16 18:46:55 EET 2004
-# Whom: Anton Yudin <toha@FreeBSD.org>
-#
+# Created by: Anton Yudin <toha@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= warmux
DISTVERSION= 11.04.1
@@ -13,7 +9,7 @@ MASTER_SITES= http://download.gna.org/${PORTNAME}/ \
http://download.gna.org/${PORTNAME}/archive/
MAINTAINER= makc@FreeBSD.org
-COMMENT= Wormux game
+COMMENT= Turn-based artillery game with free software mascots
LIB_DEPENDS= xml++-2.6.2:${PORTSDIR}/textproc/libxml++26 \
curl:${PORTSDIR}/ftp/curl
@@ -30,7 +26,7 @@ USE_DOS2UNIX= fixed_class.h
MANCOMPRESSED= no
MAN6= warmux.6
-OPTIONS_DEFINE= FRIBIDI SERVER NLS
+OPTIONS_DEFINE= FRIBIDI SERVER NLS DEBUG
FRIBIDI_DESC= Enable bi-directional unicode support
SERVER_DESC= Enable dedicated server
@@ -44,7 +40,7 @@ post-patch:
${REINPLACE_CMD} -e "s,warmux_files.desktop,," ${WRKSRC}/data/Makefile.in
${FIND} -d ${WRKSRC}/data/ -name "*.*~" -delete
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug \
--enable-logging
.endif