aboutsummaryrefslogtreecommitdiffstats
path: root/games/warmux
diff options
context:
space:
mode:
Diffstat (limited to 'games/warmux')
-rw-r--r--games/warmux/Makefile20
-rw-r--r--games/warmux/pkg-plist2
2 files changed, 22 insertions, 0 deletions
diff --git a/games/warmux/Makefile b/games/warmux/Makefile
index 91dbac2963c0..88170ef8dea1 100644
--- a/games/warmux/Makefile
+++ b/games/warmux/Makefile
@@ -28,6 +28,12 @@ USE_DOS2UNIX= fixed_class.h
MANCOMPRESSED= no
MAN6= wormux.6
+OPTIONS+= NLS "Native Language Support via gettext utilities" on \
+ FRIBIDI "Enable bi-directional unicode support" off \
+ SERVER "Enable dedicated server" off
+
+.include <bsd.port.options.mk>
+
post-patch:
${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/Makefile.in \
${WRKSRC}/src/Makefile.in
@@ -43,4 +49,18 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+.if defined(WITH_SERVER)
+PLIST_SUB+= SERVER=""
+CONFIGURE_ARGS+= --enable-servers
+.else
+PLIST_SUB+= SERVER="@comment "
+.endif
+
+.if defined(WITH_FRIBIDI)
+LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
+CONFIGURE_ARGS+= --enable-fribidi
+.else
+CONFIGURE_ARGS+= --disable-fribidi
+.endif
+
.include <bsd.port.mk>
diff --git a/games/warmux/pkg-plist b/games/warmux/pkg-plist
index a8c153e19e82..09b686026baf 100644
--- a/games/warmux/pkg-plist
+++ b/games/warmux/pkg-plist
@@ -1,5 +1,7 @@
bin/wormux
+%%SERVER%%bin/wormux-index-server
bin/wormux-list-games
+%%SERVER%%bin/wormux-server
share/applications/wormux.desktop
%%NLS%%share/locale/bg/LC_MESSAGES/wormux.mo
%%NLS%%share/locale/bs/LC_MESSAGES/wormux.mo