aboutsummaryrefslogtreecommitdiffstats
path: root/games/wesnoth/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/wesnoth/Makefile')
-rw-r--r--games/wesnoth/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index de4b0ab97ebd..e4220a044293 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -63,6 +63,11 @@ PLIST_FILES+= man/${manlang}/man6/wesnoth.6.gz
CONFIGURE_ARGS+= --enable-debug
.endif
+# XXX: breaks compilation because of -Werror
+.if !defined(WITH_STRICT)
+CONFIGURE_ARGS+= --disable-strict-compilation
+.endif
+
.if defined(WITHOUT_CAMPAIGN)
PLIST_SUB+= CAMPAIGN="@comment "
.else