aboutsummaryrefslogtreecommitdiffstats
path: root/games/windstille/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/windstille/Makefile')
-rw-r--r--games/windstille/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/windstille/Makefile b/games/windstille/Makefile
index c320661c48b9..77f8e78aa900 100644
--- a/games/windstille/Makefile
+++ b/games/windstille/Makefile
@@ -29,6 +29,7 @@ USE_SCONS= yes
USE_GL= gl
USE_SDL= sdl image
USE_BISON= build
+MAKE_JOBS_SAFE= yes
post-extract:
@${RM} -rf ${WRKSRC}/lib ${WRKSRC}/data/music/*
@@ -40,6 +41,8 @@ post-patch:
${WRKSRC}/src/SConscript
@${REINPLACE_CMD} -e 's|PHYSFS_getBaseDir()|""|' ${WRKSRC}/src/windstille_main.cpp
@${REINPLACE_CMD} -e 's|bison|${LOCALBASE}/bin/&|' ${WRKSRC}/tools/SConscript
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|; s|freetype-config|${LOCALBASE}/bin/&|' \
+ ${WRKSRC}/SConstruct ${WRKSRC}/src/SConscript
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/windstille ${PREFIX}/bin/