aboutsummaryrefslogtreecommitdiffstats
path: root/games/wolfpack/files
diff options
context:
space:
mode:
Diffstat (limited to 'games/wolfpack/files')
-rw-r--r--games/wolfpack/files/build.conf.tmpl2
-rw-r--r--games/wolfpack/files/patch-aa45
-rw-r--r--games/wolfpack/files/patch-ab26
-rw-r--r--games/wolfpack/files/patch-ac26
-rw-r--r--games/wolfpack/files/patch-ad21
-rw-r--r--games/wolfpack/files/patch-ae14
-rw-r--r--games/wolfpack/files/patch-af14
-rw-r--r--games/wolfpack/files/patch-ag36
-rw-r--r--games/wolfpack/files/patch-ah13
-rw-r--r--games/wolfpack/files/patch-ai10
10 files changed, 157 insertions, 50 deletions
diff --git a/games/wolfpack/files/build.conf.tmpl b/games/wolfpack/files/build.conf.tmpl
index a18454a1916c..aac00fe3d744 100644
--- a/games/wolfpack/files/build.conf.tmpl
+++ b/games/wolfpack/files/build.conf.tmpl
@@ -32,7 +32,7 @@ EMPDIR = %%EMPDIR%%
# Please enter the C-compiler you are using (full path is allowed):
# (For NT builds using MSVC 5.0, use "CC = CL")
-CC = gcc
+CC = %%CC%%
# Please enter the linker you are using (full path is allowed):
LD = ld
diff --git a/games/wolfpack/files/patch-aa b/games/wolfpack/files/patch-aa
index 4e8438c13e52..14d7a3c09ba2 100644
--- a/games/wolfpack/files/patch-aa
+++ b/games/wolfpack/files/patch-aa
@@ -1,5 +1,14 @@
---- Makefile.orig Tue Feb 16 01:06:47 1999
-+++ Makefile Tue Oct 26 14:56:09 1999
+--- Makefile.orig Mon Sep 25 16:11:49 2000
++++ Makefile Sun Dec 17 00:12:03 2000
+@@ -34,7 +34,7 @@
+ include Make.sysdefs
+
+ TOBUILD = all
+-GENMASTER = $(TOBUILD) GLOBALCFLAGS="$(GLOBALCFLAGS)" GLOBALLFLAGS="$(GLOBALLFLAGS)"
++GENMASTER = $(TOBUILD) GLOBALCFLAGS="$(CFLAGS) $(GLOBALCFLAGS)" GLOBALLFLAGS="$(GLOBALLFLAGS)"
+ CLIENTLIBS = -ltermcap
+
+
@@ -80,7 +80,6 @@
($(MAKE) genlibs $(ALPHAMASTER))
(cd src/lib/lwp; $(MAKE) $(ALPHAMASTER))
@@ -35,7 +44,7 @@
@@ -112,7 +108,6 @@
($(MAKE) genlibs $(HPMASTER))
(cd src/lib/lwp; $(MAKE) $(HPMASTER))
- ($(MAKE) binaries $(HPMASTER) CLIENTLIBS="")
+ ($(MAKE) binaries $(HPMASTER))
- ($(MAKE) install)
hpux:
@@ -128,7 +137,15 @@
nt:
@echo 'building a $(WORLDX) by $(WORLDY) server...'
-@@ -222,7 +206,6 @@
+@@ -214,7 +198,6 @@
+ $(MAKE) nt $(NTMASTER)
+ cd ../../..
+ $(MAKE) ntbinaries TOBUILD=nt $(NTMASTER)
+- $(MAKE) ntinstall
+
+ vaxultrix:
+ @echo 'building a $(WORLDX) by $(WORLDY) server...'
+@@ -222,7 +205,6 @@
($(MAKE) genlibs $(VAXULTMASTER))
(cd src/lib/lwp; $(MAKE) $(VAXULTMASTER))
($(MAKE) binaries $(VAXULTMASTER))
@@ -136,7 +153,7 @@
aix:
@echo 'building a $(WORLDX) by $(WORLDY) server...'
-@@ -230,7 +213,6 @@
+@@ -230,7 +212,6 @@
($(MAKE) genlibs $(AIXMASTER))
(cd src/lib/lwp; $(MAKE) aix $(AIXMASTER))
($(MAKE) binaries $(AIXMASTER))
@@ -144,7 +161,7 @@
rtpc:
@echo 'building a $(WORLDX) by $(WORLDY) server...'
-@@ -238,7 +220,6 @@
+@@ -238,7 +219,6 @@
($(MAKE) genlibs $(RTPCMASTER))
(cd src/lib/lwp; $(MAKE) aix $(RTPCMASTER))
($(MAKE) binaries $(RTPCMASTER))
@@ -152,7 +169,7 @@
sequent:
@echo 'building a $(WORLDX) by $(WORLDY) server...'
-@@ -246,7 +227,6 @@
+@@ -246,7 +226,6 @@
($(MAKE) genlibs $(SEQMASTER))
(cd src/lib/lwp; $(MAKE) $(SEQMASTER))
($(MAKE) binaries $(SEQMASTER))
@@ -160,7 +177,7 @@
sequent.fpa:
@echo 'building a $(WORLDX) by $(WORLDY) server...'
-@@ -254,7 +234,6 @@
+@@ -254,7 +233,6 @@
($(MAKE) genlibs $(SEQFPAMASTER))
(cd src/lib/lwp; $(MAKE) $(SEQFPAMASTER))
($(MAKE) binaries $(SEQFPAMASTER))
@@ -168,7 +185,7 @@
solaris:
@echo 'building a $(WORLDX) by $(WORLDY) server...'
-@@ -262,7 +241,6 @@
+@@ -262,7 +240,6 @@
($(MAKE) genlibs $(SOLMASTER))
(cd src/lib/lwp; $(MAKE) $(SOLMASTER))
($(MAKE) binaries $(SOLMASTER))
@@ -176,7 +193,7 @@
sun3:
@echo 'building a $(WORLDX) by $(WORLDY) server...'
-@@ -270,7 +248,6 @@
+@@ -270,7 +247,6 @@
($(MAKE) genlibs $(SUN3MASTER))
(cd src/lib/lwp; $(MAKE) $(SUN3MASTER))
($(MAKE) binaries $(SUN3MASTER))
@@ -184,7 +201,7 @@
sun4:
@echo 'building a $(WORLDX) by $(WORLDY) server...'
-@@ -278,7 +255,6 @@
+@@ -278,7 +254,6 @@
($(MAKE) genlibs $(SUN4MASTER))
(cd src/lib/lwp; $(MAKE) $(SUN4MASTER))
($(MAKE) binaries $(SUN4MASTER))
@@ -192,7 +209,7 @@
sun4.opt:
@echo 'building a $(WORLDX) by $(WORLDY) server...'
-@@ -286,7 +262,6 @@
+@@ -286,7 +261,6 @@
($(MAKE) genlibs $(SUN4OPTMASTER))
(cd src/lib/lwp; $(MAKE) $(SUN4OPTMASTER))
($(MAKE) binaries $(SUN4OPTMASTER))
@@ -200,7 +217,7 @@
sun4.debug:
@echo 'building a $(WORLDX) by $(WORLDY) server...'
-@@ -294,7 +269,6 @@
+@@ -294,7 +268,6 @@
($(MAKE) genlibs $(SUN4DBGMASTER))
(cd src/lib/lwp; $(MAKE) $(SUN4DBGMASTER))
($(MAKE) binaries $(SUN4DBGMASTER))
@@ -208,7 +225,7 @@
#
# Generic stuff that is called from the architecture specific stuff.
-@@ -527,9 +501,16 @@
+@@ -528,9 +501,16 @@
# data directory if you didn't have one before.
install:
diff --git a/games/wolfpack/files/patch-ab b/games/wolfpack/files/patch-ab
index ecd4e0c1a684..24b36823a945 100644
--- a/games/wolfpack/files/patch-ab
+++ b/games/wolfpack/files/patch-ab
@@ -1,12 +1,14 @@
-diff -u -r ./include/misc.h ../emp4.patched/include/misc.h
---- ./include/misc.h Wed Nov 18 10:12:29 1998
-+++ ../emp4.patched/include/misc.h Tue Oct 26 10:55:54 1999
-@@ -181,7 +181,7 @@
- extern char *calloc();
- #endif
- #else
--#if !defined(ALPHA) && !defined(__osf__) && !defined(ultrix) && !defined(hpux) && !defined(FBSD)
-+#if !defined(ALPHA) && !defined(__osf__) && !defined(ultrix) && !defined(hpux) && !defined(__FreeBSD__)
- extern char *malloc();
- extern char *calloc();
- #endif
+--- src/lib/lwp/lwp.c.orig Sat Dec 16 22:53:35 2000
++++ src/lib/lwp/lwp.c Sat Dec 16 22:54:05 2000
+@@ -23,7 +23,11 @@
+
+ #include <stdio.h>
+ #include <signal.h>
++#if defined(__FreeBSD__)
++#include <stdlib.h>
++#else
+ #include <malloc.h>
++#endif
+ #include <string.h>
+ #include "lwp.h"
+ #include "lwpint.h"
diff --git a/games/wolfpack/files/patch-ac b/games/wolfpack/files/patch-ac
index 40083006bb6d..7ca0cc2e682d 100644
--- a/games/wolfpack/files/patch-ac
+++ b/games/wolfpack/files/patch-ac
@@ -1,14 +1,14 @@
---- src/doconfig/Makefile Wed Nov 18 10:12:40 1998
-+++ src/doconfig/Makefile.orig Tue Oct 26 15:13:55 1999
-@@ -53,7 +53,10 @@
- @echo 'globalcflags = $(GLOBALCFLAGS)'
- @echo 'globallflags = $(GLOBALLFLAGS)'
- $(CC) $(GLOBALCFLAGS) $(DALL) doconfig.c -o doconfig $(GLOBALLFLAGS)
-- ./doconfig
-+ ./doconfig config
-+
-+install: doconfig
-+ ./doconfig install
-
- nt: ntdoconfig
+--- src/lib/lwp/sel.c.orig Sat Dec 16 18:54:06 2000
++++ src/lib/lwp/sel.c Sat Dec 16 18:54:25 2000
+@@ -31,7 +31,11 @@
+ * Dave Pare, 1994
+ */
++#if defined(__FreeBSD__)
++#include <stdlib.h>
++#else
+ #include <malloc.h>
++#endif
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/uio.h>
diff --git a/games/wolfpack/files/patch-ad b/games/wolfpack/files/patch-ad
index ccb8e8b513b6..8cf145371aab 100644
--- a/games/wolfpack/files/patch-ad
+++ b/games/wolfpack/files/patch-ad
@@ -1,6 +1,6 @@
---- src/doconfig/doconfig.c Sun Jan 17 03:14:13 1999
-+++ src/doconfig/doconfig.c.orig Tue Oct 26 15:13:27 1999
-@@ -91,12 +91,17 @@
+--- src/doconfig/doconfig.c.orig Sat Dec 16 18:08:03 2000
++++ src/doconfig/doconfig.c Sat Dec 16 18:49:52 2000
+@@ -90,12 +90,18 @@
#endif
int
@@ -12,14 +12,15 @@
char *pathname;
+ if (argc != 2) {
-+ printf("Bad usage");
-+ exit(-1);
++ printf("Bad usage");
++ exit(-1);
+ }
+
++
if ((pathname = getcwd(NULL, 255)) == NULL) {
printf("Can't get current path!\n");
exit(-1);
-@@ -113,13 +118,14 @@
+@@ -112,13 +118,15 @@
cp = (char *)rindex(pathname, '\\');
*cp = '\0';
#endif
@@ -32,14 +33,14 @@
wripglob(buf);
-
+ } else {
++ printf("Installing...\n");
if (access(EP, 0)) {
printf("making directory %s\n", EP);
if (mkdir(EP, 493)) {
-@@ -139,6 +145,7 @@
+@@ -136,6 +144,7 @@
+ }
+ sprintf(buf, "%s/data/auth", EP);
wrauth(buf);
- sprintf(buf, "%s/data/hours", EP);
- wrhours(buf);
+ }
exit(0);
}
-
diff --git a/games/wolfpack/files/patch-ae b/games/wolfpack/files/patch-ae
new file mode 100644
index 000000000000..5b0204f9ecf5
--- /dev/null
+++ b/games/wolfpack/files/patch-ae
@@ -0,0 +1,14 @@
+--- src/lib/lwp/sem.c.orig Sat Dec 16 18:54:39 2000
++++ src/lib/lwp/sem.c Sat Dec 16 18:55:01 2000
+@@ -20,7 +20,11 @@
+ * Imperial College of Science, Technology and Medicine, 180 Queen's
+ * Gate, London SW7 2BZ, England.
+ */
++#if defined(__FreeBSD__)
++#include <stdlib.h>
++#else
+ #include <malloc.h>
++#endif
+ #include <string.h>
+
+ #include "lwp.h"
diff --git a/games/wolfpack/files/patch-af b/games/wolfpack/files/patch-af
new file mode 100644
index 000000000000..f7c81c9c9a96
--- /dev/null
+++ b/games/wolfpack/files/patch-af
@@ -0,0 +1,14 @@
+--- src/lib/lwp/misc/echo.c.orig Sat Dec 16 18:55:16 2000
++++ src/lib/lwp/misc/echo.c Sat Dec 16 18:55:41 2000
+@@ -5,7 +5,11 @@
+ *
+ */
+
++#if defined(__FreeBSD__)
++#include <stdlib.h>
++#else
+ #include <malloc.h>
++#endif
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
diff --git a/games/wolfpack/files/patch-ag b/games/wolfpack/files/patch-ag
new file mode 100644
index 000000000000..cd9d5d64400b
--- /dev/null
+++ b/games/wolfpack/files/patch-ag
@@ -0,0 +1,36 @@
+--- src/lib/commands/mfir.c.orig Sat Mar 11 15:36:42 2000
++++ src/lib/commands/mfir.c Sat Dec 16 22:45:46 2000
+@@ -522,6 +522,7 @@
+ }
+ }
+ */
++ /* Now check treaties, based on the target */
+ switch (target) {
+ case targ_ship:
+ if (!trechk(player->cnum, vict, SEAFIR))
+@@ -531,9 +532,13 @@
+ if (!trechk(player->cnum, vict, SUBFIR))
+ continue;
+ break;
+- default:
++ case targ_unit:
++ case targ_land:
+ if (!trechk(player->cnum, vict, LANFIR))
+ continue;
++ break;
++ default:
++ break;
+ }
+
+ if (opt_SLOW_WAR) {
+@@ -614,6 +619,10 @@
+
+ break ;
+ }
++ /* Ok, now, check if we had a bogus target. If so,
++ just continue on, since there is no defender. */
++ if (target == targ_bogus)
++ continue;
+ if (attacker == targ_unit){
+ attacker = targ_land;
+ getsect(fland.lnd_x,fland.lnd_y,&fsect);
diff --git a/games/wolfpack/files/patch-ah b/games/wolfpack/files/patch-ah
new file mode 100644
index 000000000000..ea4eae8db8a8
--- /dev/null
+++ b/games/wolfpack/files/patch-ah
@@ -0,0 +1,13 @@
+--- src/doconfig/Makefile.orig Sat Dec 16 22:57:15 2000
++++ src/doconfig/Makefile Sat Dec 16 22:58:25 2000
+@@ -53,7 +53,10 @@
+ @echo 'globalcflags = $(GLOBALCFLAGS)'
+ @echo 'globallflags = $(GLOBALLFLAGS)'
+ $(CC) $(GLOBALCFLAGS) $(DALL) doconfig.c -o doconfig $(GLOBALLFLAGS)
+- ./doconfig
++ ./doconfig config
++
++install: doconfig
++ ./doconfig install
+
+ nt: ntdoconfig
diff --git a/games/wolfpack/files/patch-ai b/games/wolfpack/files/patch-ai
new file mode 100644
index 000000000000..6050bcc516ce
--- /dev/null
+++ b/games/wolfpack/files/patch-ai
@@ -0,0 +1,10 @@
+--- Make.sysdefs.orig Sun Dec 17 00:09:26 2000
++++ Make.sysdefs Sun Dec 17 00:09:13 2000
+@@ -32,7 +32,7 @@
+ #
+
+ FREEBSDRANLIB = /usr/bin/ranlib
+-FREEBSDCFLAGS = -DRel4 -DFBSD -ansi -pedantic #-Wall
++FREEBSDCFLAGS = $(CFLAGS) -DRel4 -DFBSD -ansi -pedantic #-Wall
+ FREEBSDLFLAGS =
+ FREEBSDMASTER = GLOBALCFLAGS="$(FREEBSDCFLAGS)" GLOBALLFLAGS="$(FREEBSDLFLAGS)" RANLIB="$(FREEBSDRANLIB)"