aboutsummaryrefslogtreecommitdiffstats
path: root/games/xmines/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/xmines/Makefile')
-rw-r--r--games/xmines/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/games/xmines/Makefile b/games/xmines/Makefile
index 20fa6b200587..1575d9a78cad 100644
--- a/games/xmines/Makefile
+++ b/games/xmines/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: xmines
-# Date created: 18 August 1999
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= xmines
PORTVERSION= 1.0
PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITES= SUNSITE
MASTER_SITE_SUBDIR= games/strategy
DISTNAME= ${PORTNAME}
@@ -17,11 +13,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Minesweeper game for the X Window System
USE_XORG= x11 xt
+CFLAGS+= -Wno-error=return-type
+
+PORTDOCS= README
+
+.include <bsd.port.options.mk>
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>