aboutsummaryrefslogtreecommitdiffstats
path: root/games/xpat2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/xpat2/Makefile')
-rw-r--r--games/xpat2/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/games/xpat2/Makefile b/games/xpat2/Makefile
index fac91481cfcd..5927eda78e9f 100644
--- a/games/xpat2/Makefile
+++ b/games/xpat2/Makefile
@@ -6,21 +6,26 @@
#
PORTNAME= xpat2
-PORTVERSION= 1.06
+PORTVERSION= 1.07
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/solitaires
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
MAINTAINER= mph@freebsd.org
-USE_X_PREFIX= yes
+USE_IMAKE= yes
USE_XPM= yes
MAN6= xpat2.6
+MANCOMPRESSED= no
post-install:
- ${TOUCH} $(PREFIX)/lib/X11/xpat/xpat.log
- ${CHOWN} root.games $(PREFIX)/lib/X11/xpat/xpat.log $(PREFIX)/bin/xpat2
+ ${MV} ${PREFIX}/lib/xpat/man/man6/xpat2.6x ${PREFIX}/man/man6/xpat2.6
+ ${RMDIR} ${PREFIX}/lib/xpat/man/man6 ${PREFIX}/lib/xpat/man
+ ${TOUCH} /var/games/xpat.log
+ ${CHOWN} root:games /var/games/xpat.log $(PREFIX)/bin/xpat2
${CHMOD} 2555 $(PREFIX)/bin/xpat2
- ${CHMOD} 664 $(PREFIX)/lib/X11/xpat/xpat.log
+ ${CHMOD} 664 /var/games/xpat.log
.include <bsd.port.mk>