aboutsummaryrefslogtreecommitdiffstats
path: root/games/xpilot-ng/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/xpilot-ng/Makefile')
-rw-r--r--games/xpilot-ng/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/games/xpilot-ng/Makefile b/games/xpilot-ng/Makefile
new file mode 100644
index 000000000000..c145dde72d7f
--- /dev/null
+++ b/games/xpilot-ng/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: xpilot-ng
+# Date created: 11 Sep 2003
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xpilot-ng
+PORTVERSION= 4.5.4X2
+CATEGORIES= games
+MASTER_SITES= http://www.hut.fi/~ksoderbl/xpilot/
+DISTNAME= xpilot-${PORTVERSION}
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= An enhanced version of XPilot
+
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ARGS= --program-suffix=-ng
+
+.include <bsd.port.mk>