aboutsummaryrefslogtreecommitdiffstats
path: root/games/xpipeman/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/xpipeman/Makefile')
-rw-r--r--games/xpipeman/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/games/xpipeman/Makefile b/games/xpipeman/Makefile
index f69538073307..47f92d5496cb 100644
--- a/games/xpipeman/Makefile
+++ b/games/xpipeman/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: xpipeman
-# Date created: 2 Jan 1995
-# Whom: swallace
-#
+# Created by: swallace
# $FreeBSD$
-#
PORTNAME= xpipeman
PORTVERSION= 1.0
PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITES= SUNSITE
MASTER_SITE_SUBDIR= games/strategy
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tar.Z
@@ -23,8 +19,14 @@ ONLY_FOR_ARCHS= i386 amd64
USE_IMAKE= yes
USE_XORG= x11 xaw xext xmu xt sm ice
MAN6= xpipeman.6
+MANCOMPRESSED= no
+CFLAGS+= -Wno-error=return-type
+BINGRP= games
+BINMODE= 2555
-post-install:
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xpipeman ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xpipeman.man ${MANPREFIX}/man/man6/xpipeman.6
${INSTALL} -c -g games -m 664 ${FILESDIR}/xpipescores ${PREFIX}/lib/X11
.include <bsd.port.mk>