aboutsummaryrefslogtreecommitdiffstats
path: root/games/xtet42
diff options
context:
space:
mode:
Diffstat (limited to 'games/xtet42')
-rw-r--r--games/xtet42/Makefile27
-rw-r--r--games/xtet42/pkg-plist10
2 files changed, 21 insertions, 16 deletions
diff --git a/games/xtet42/Makefile b/games/xtet42/Makefile
index 3c8ecab2aeb2..e44719562743 100644
--- a/games/xtet42/Makefile
+++ b/games/xtet42/Makefile
@@ -7,27 +7,32 @@
PORTNAME= xtet42
PORTVERSION= 2.21
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= http://utenti.gufi.org/~gmarco/files/distfiles/
+MASTER_SITES= http://utenti.gufi.org/~gmarco/files/distfiles/
MAINTAINER= gmarco@gufi.org
COMMENT= A one or two player t*tris game
-USE_X_PREFIX= yes
-HAS_CONFIGURE= yes
+USE_XLIB= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-setgid=games
MAN6= xtet42.6
+post-patch:
+ @${REINPLACE_CMD} -e 's,^hiscoredir.*,hiscoredir=${DATADIR},' \
+ ${WRKSRC}/Makefile.in
+
do-install:
- ${MKDIR} ${PREFIX}/lib/X11/xtet42
- @${CHOWN} root:games ${PREFIX}/lib/X11/xtet42
- @${CHMOD} 775 ${PREFIX}/lib/X11/xtet42
+ ${MKDIR} ${DATADIR}
+ @${CHOWN} root:games ${DATADIR}
+ @${CHMOD} 775 ${DATADIR}
${INSTALL} -c -m 2755 -g games ${WRKSRC}/xtet42 ${PREFIX}/bin
- ${INSTALL} -c -m 664 -g games ${WRKSRC}/xtet42.hiscore ${PREFIX}/lib/X11/xtet42/.xtet42.hiscore
- ${INSTALL} -c -m 664 -g games ${WRKSRC}/xtet42.hiscore.single ${PREFIX}/lib/X11/xtet42/.xtet42.hiscore.single
- ${INSTALL} -c -m 664 -g games /dev/null ${PREFIX}/lib/X11/xtet42/.xtet42.unlock
- ${INSTALL} -c -m 664 -g games /dev/null ${PREFIX}/lib/X11/xtet42/.xtet42.log
- ${INSTALL_MAN} ${WRKSRC}/xtet42.6 ${PREFIX}/man/man6
+ ${INSTALL} -c -m 664 -g games ${WRKSRC}/xtet42.hiscore ${DATADIR}/.xtet42.hiscore
+ ${INSTALL} -c -m 664 -g games ${WRKSRC}/xtet42.hiscore.single ${DATADIR}/.xtet42.hiscore.single
+ ${INSTALL} -c -m 664 -g games /dev/null ${DATADIR}/.xtet42.unlock
+ ${INSTALL} -c -m 664 -g games /dev/null ${DATADIR}/.xtet42.log
+ ${INSTALL_MAN} ${WRKSRC}/xtet42.6 ${MANPREFIX}/man/man6
.include <bsd.port.mk>
diff --git a/games/xtet42/pkg-plist b/games/xtet42/pkg-plist
index 200c93a59621..7ab51b07bd8f 100644
--- a/games/xtet42/pkg-plist
+++ b/games/xtet42/pkg-plist
@@ -1,6 +1,6 @@
bin/xtet42
-lib/X11/xtet42/.xtet42.hiscore.single
-lib/X11/xtet42/.xtet42.hiscore
-lib/X11/xtet42/.xtet42.unlock
-lib/X11/xtet42/.xtet42.log
-@dirrm lib/X11/xtet42
+%%DATADIR%%/.xtet42.hiscore.single
+%%DATADIR%%/.xtet42.hiscore
+%%DATADIR%%/.xtet42.unlock
+%%DATADIR%%/.xtet42.log
+@dirrm %%DATADIR%%