aboutsummaryrefslogtreecommitdiffstats
path: root/games/zangband/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/zangband/Makefile')
-rw-r--r--games/zangband/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/games/zangband/Makefile b/games/zangband/Makefile
index 42b703292f04..9192507e030e 100644
--- a/games/zangband/Makefile
+++ b/games/zangband/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zangband
-# Date created: 29 May 2000
-# Whom: Makoto YAMAKURA <makoto@pinpott.spnet.ne.jp>
-#
+# Created by: Makoto YAMAKURA <makoto@pinpott.spnet.ne.jp>
# $FreeBSD$
-#
PORTNAME= zangband
PORTVERSION= 2.6.2
@@ -38,10 +34,11 @@ ANGBANDLIB?= lib/${PORTNAME}
ANGBANDBIN?= bin/${PORTNAME}
pre-patch:
- @${PERL} -pi.orig -e 's|^aclocal|${ACLOCAL}|; \
- s|^autoheader|${AUTOHEADER}|; \
- s|^automake|${AUTOMAKE}|; s|^autoconf|${AUTOCONF}|' \
- ${WRKSRC}/bootstrap
+ @${REINPLACE_CMD} -i '' -e 's|^aclocal|${ACLOCAL}|' \
+ -e 's|^autoheader|${AUTOHEADER}|' \
+ -e 's|^automake|${AUTOMAKE}|' \
+ -e 's|^autoconf|${AUTOCONF}|' \
+ ${WRKSRC}/bootstrap
pre-configure:
(cd ${WRKSRC} ; ${SH} bootstrap)