aboutsummaryrefslogtreecommitdiffstats
path: root/games/zaz/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/zaz/Makefile')
-rw-r--r--games/zaz/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/games/zaz/Makefile b/games/zaz/Makefile
index 4673f943b6c3..b0932d62cf74 100644
--- a/games/zaz/Makefile
+++ b/games/zaz/Makefile
@@ -10,10 +10,10 @@ MASTER_SITES= SF/${PORTNAME}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A puzzle game where the player has to arrange balls in triplets
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
- theora:${PORTSDIR}/multimedia/libtheora \
- vorbis:${PORTSDIR}/audio/libvorbis \
- ftgl:${PORTSDIR}/graphics/ftgl
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libtheora.so:${PORTSDIR}/multimedia/libtheora \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libftgl.so:${PORTSDIR}/graphics/ftgl
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -26,8 +26,10 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ARGS= --with-icondir="${PREFIX}/share/pixmaps"
PORTDOCS= *
+PORTDATA= *
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
# Unconditially disable NLS for now: the game segfaults with 8bit locales
@@ -42,9 +44,5 @@ PLIST_SUB+= NLS="@comment "
post-patch:
@${REINPLACE_CMD} -e '/^zazdocdir =/ s|$${prefix}/doc|$${prefix}/share/doc|' \
${WRKSRC}/Makefile.in
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-dist_docDATA||' \
- ${WRKSRC}/Makefile.in
-.endif
.include <bsd.port.mk>