aboutsummaryrefslogtreecommitdiffstats
path: root/games/zdoom
diff options
context:
space:
mode:
Diffstat (limited to 'games/zdoom')
-rw-r--r--games/zdoom/Makefile42
-rw-r--r--games/zdoom/distinfo3
-rw-r--r--games/zdoom/pkg-descr17
3 files changed, 62 insertions, 0 deletions
diff --git a/games/zdoom/Makefile b/games/zdoom/Makefile
new file mode 100644
index 000000000000..fd1d032b90dd
--- /dev/null
+++ b/games/zdoom/Makefile
@@ -0,0 +1,42 @@
+# Created by: Kyle Evans <bsdports@kyle-evans.net>
+# $FreeBSD$
+
+PORTNAME= zdoom
+PORTVERSION= 2.8.1
+CATEGORIES= games
+
+MAINTAINER= bsdports@kyle-evans.net
+COMMENT= Source port for Doom-engine games
+
+BUILD_DEPENDS= zip:archivers/zip
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libsndfile.so:audio/libsndfile
+
+USE_GITHUB= yes
+GH_ACCOUNT= rheit
+
+USES= cmake:outsource gettext jpeg openal pkgconfig
+USE_GNOME= atk cairo gdkpixbuf2 gtk20 pango
+USE_SDL= sdl2
+CMAKE_ARGS= -DNO_FMOD:BOOL=ON
+CMAKE_BUILD_TYPE?= Release
+
+PLIST_FILES= bin/${PORTNAME} \
+ %%DATADIR%%/${PORTNAME}.pk3
+
+OPTIONS_DEFINE= FLUIDSYNTH
+OPTIONS_DEFAULT=FLUIDSYNTH
+
+FLUIDSYNTH_DESC= FluidSynth sound library support
+FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
+FLUIDSYNTH_CMAKE_BOOL= WITH_FLUIDSYNTH
+
+.include "${.CURDIR}/../doom-data/Makefile.include"
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${CONFIGURE_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${CONFIGURE_WRKSRC}/${PORTNAME}.pk3 ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/zdoom/distinfo b/games/zdoom/distinfo
new file mode 100644
index 000000000000..3e3c911685c3
--- /dev/null
+++ b/games/zdoom/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470284266
+SHA256 (rheit-zdoom-2.8.1_GH0.tar.gz) = ed8297563268e6b3187c025e9f375369b36c8325291d0f42b33aff55031954a2
+SIZE (rheit-zdoom-2.8.1_GH0.tar.gz) = 4767366
diff --git a/games/zdoom/pkg-descr b/games/zdoom/pkg-descr
new file mode 100644
index 000000000000..846943900e65
--- /dev/null
+++ b/games/zdoom/pkg-descr
@@ -0,0 +1,17 @@
+ZDoom is an enhanced source port of ID Software's DOOM engine. It is based on
+the source code of id Software's DOOM. ZDoom boasts enhanced modding support,
+as well as support for the following games:
+
+* Ultimate Doom
+* Doom II
+* Final Doom
+* Heretic
+* Hexen
+* Strife
+* Chex Quest (1 & 3)
+* Action Doom II
+* Harmony v1.1
+* Hacx
+* The Adventures of Square
+
+WWW: http://www.zdoom.org/