aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/netwalk/Makefile64
-rw-r--r--games/netwalk/distinfo4
-rw-r--r--games/netwalk/pkg-descr9
4 files changed, 78 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index a5a44bfb15c3..eb5ec15229eb 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -595,6 +595,7 @@
SUBDIR += netris
SUBDIR += netspades
SUBDIR += nettoe
+ SUBDIR += netwalk
SUBDIR += neverball
SUBDIR += newvox
SUBDIR += nextgo
diff --git a/games/netwalk/Makefile b/games/netwalk/Makefile
new file mode 100644
index 000000000000..b264b290866a
--- /dev/null
+++ b/games/netwalk/Makefile
@@ -0,0 +1,64 @@
+# $FreeBSD$
+
+PORTNAME= netwalk
+PORTVERSION= 0.4.10
+CATEGORIES= games
+MASTER_SITES= GITHUB \
+ GOOGLE_CODE:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ screenshot-0.4.8.png:icons
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Game where the object is to connect every terminal to the main server
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= blynn
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= master
+GH_COMMIT= 634e7c9
+
+USE_SDL= sdl ttf
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_XORG= x11 xau xdmcp
+ALL_TARGET=
+MAKE_JOBS_SAFE= yes
+
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/netwalk/Vera.ttf \
+ share/pixmaps/${PORTNAME}.png
+PLIST_DIRSTRY= share/netwalk
+
+PORTDOCS= README
+
+DESKTOP_ENTRIES="NetWalk" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;LogicGame;" "false"
+
+.include <bsd.port.options.mk>
+
+post-patch:
+# Fix SDL, CFLAGS, PREFIX
+ @${REINPLACE_CMD} \
+ -e 's|sdl-config|$(SDL_CONFIG)|' \
+ -e 's|CC=gcc|CC?=g++|' \
+ -e 's|CFLAGS=-Wall -O2 -fomit-frame-pointer|CFLAGS+=-Wall -O2 -fomit-frame-pointer|' \
+ -e 's|PREFIX = /usr|PREFIX = ${PREFIX}|' \
+ ${WRKSRC}/Makefile
+
+post-install:
+# Pixmaps
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/screenshot-0.4.8.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/netwalk/distinfo b/games/netwalk/distinfo
new file mode 100644
index 000000000000..155459f16786
--- /dev/null
+++ b/games/netwalk/distinfo
@@ -0,0 +1,4 @@
+SHA256 (netwalk/netwalk-0.4.10.tar.gz) = b7c5ad78e732e103a6ed820970f90dcf91612a8f0e5608dae58725445cda7df7
+SIZE (netwalk/netwalk-0.4.10.tar.gz) = 71244
+SHA256 (netwalk/screenshot-0.4.8.png) = 3a7c6364c77fbff203758eecb6648f876697d41c3b88e0d759af1ab3238fca22
+SIZE (netwalk/screenshot-0.4.8.png) = 1952
diff --git a/games/netwalk/pkg-descr b/games/netwalk/pkg-descr
new file mode 100644
index 000000000000..b6b304594243
--- /dev/null
+++ b/games/netwalk/pkg-descr
@@ -0,0 +1,9 @@
+NetWalk is a puzzle game where the object is to connect every terminal to the
+main server. (These are represented by coloured boxes, so you could
+also imagine them to be water mains, electricity cables, phone lines, etc.)
+
+In this version, not only must every terminal be connected, but every piece of
+cable must also be connected to the main server somehow.
+
+WWW: https://code.google.com/p/netwalk/
+WWW: https://github.com/blynn/netwalk