aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/poker-engine/Makefile7
-rw-r--r--games/poker-engine/pkg-plist14
2 files changed, 4 insertions, 17 deletions
diff --git a/games/poker-engine/Makefile b/games/poker-engine/Makefile
index c752ba5f1c15..c7b30224eb9d 100644
--- a/games/poker-engine/Makefile
+++ b/games/poker-engine/Makefile
@@ -10,19 +10,18 @@ MASTER_SITES= http://download.gna.org/pokersource/sources/
MAINTAINER= ports@FreeBSD.org
COMMENT= Python library that implements poker rules
+LICENSE= GPLv3 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync \
${PYTHON_SITELIBDIR}/pokereval.py:${PORTSDIR}/games/py-poker-eval \
${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt
-
RUN_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync \
${PYTHON_SITELIBDIR}/pokereval.py:${PORTSDIR}/games/py-poker-eval \
${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt
-LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING
-
USES= gettext gmake pkgconfig python:2
GNU_CONFIGURE= yes
diff --git a/games/poker-engine/pkg-plist b/games/poker-engine/pkg-plist
index ad98bb08ef68..9b920fa1eb1c 100644
--- a/games/poker-engine/pkg-plist
+++ b/games/poker-engine/pkg-plist
@@ -196,16 +196,4 @@ share/locale/sv/LC_MESSAGES/poker-engine.mo
%%DATADIR%%/conf/poker.payouts.xml
%%DATADIR%%/conf/poker.razz.xml
man/man8/pokerconfigupgrade.8.gz
-@dirrmtry share/locale/fr_FX/LC_MESSAGES
-@dirrmtry share/locale/fr_FX
-@dirrmtry share/locale/fr_CA/LC_MESSAGES
-@dirrmtry share/locale/fr_CA
-@dirrmtry share/locale/fr_BE/LC_MESSAGES
-@dirrmtry share/locale/fr_BE
-@dirrmtry share/locale/en_US/LC_MESSAGES
-@dirrmtry share/locale/en_US
-@dirrm %%DATADIR%%/upgrades
-@dirrm %%DATADIR%%/conf
-@dirrm %%DATADIR%%
-@dirrm %%PYTHON_SITELIBDIR%%/pokerengine
-@dirrm %%ETCDIR%%
+@dir %%DATADIR%%/upgrades