aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/meritous/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/games/meritous/Makefile b/games/meritous/Makefile
index 08b6fc586ba7..a805916f5959 100644
--- a/games/meritous/Makefile
+++ b/games/meritous/Makefile
@@ -15,16 +15,16 @@ COMMENT= Action-adventure dungeon crawl game
LICENSE= GPLv3
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
USE_SDL= sdl mixer image
ALL_TARGET= default
USE_DOS2UNIX= dat/d/helpfile.txt src/*.c
+PLIST_FILES= bin/${PORTNAME}
+
PORTDOCS= *
PORTDATA= *
-PLIST_FILES= bin/${PORTNAME}
-
DESKTOP_ENTRIES="Meritous" \
"Action-adventure dungeon crawl game" \
"${DATADIR}/i/icon.png" \
@@ -32,21 +32,17 @@ DESKTOP_ENTRIES="Meritous" \
"Game;ActionGame;AdventureGame;" \
false
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
post-patch:
@${REINPLACE_CMD} -e 's|dat/|${DATADIR}/|' ${WRKSRC}/src/*.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/meritous ${PREFIX}/bin
-.if !defined(NOPORTDATA)
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC}/dat && ${COPYTREE_SHARE} \* ${DATADIR}
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/meritous ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC}/dat && ${COPYTREE_SHARE} \* ${STAGEDIR}${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>