aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/antipolix/Makefile22
-rw-r--r--games/antipolix/pkg-plist18
2 files changed, 19 insertions, 21 deletions
diff --git a/games/antipolix/Makefile b/games/antipolix/Makefile
index 2802ad975cb6..e85e26352246 100644
--- a/games/antipolix/Makefile
+++ b/games/antipolix/Makefile
@@ -17,23 +17,21 @@ USES= imake
USE_XORG= x11
NO_INSTALL_MANPAGES= yes
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
+
pre-build:
@${TOUCH} ${WRKSRC}/client.man ${WRKSRC}/server.man
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/client ${PREFIX}/bin/antipolix-client
- ${INSTALL_PROGRAM} ${WRKSRC}/server ${PREFIX}/bin/antipolix-server
- @${MKDIR} ${PREFIX}/share/examples/antipolix
- ${INSTALL_DATA} ${WRKSRC}/.motd ${PREFIX}/share/examples/antipolix/dot.motd.sample
- ${INSTALL_DATA} ${WRKSRC}/.players ${PREFIX}/share/examples/antipolix/dot.players.sample
- ${INSTALL_DATA} ${WRKSRC}/.server_defaults ${PREFIX}/share/examples/antipolix/dot.server_defaults.sample
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${PREFIX}/share/doc/antipolix
+ ${INSTALL_PROGRAM} ${WRKSRC}/client ${STAGEDIR}${PREFIX}/bin/antipolix-client
+ ${INSTALL_PROGRAM} ${WRKSRC}/server ${STAGEDIR}${PREFIX}/bin/antipolix-server
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/.motd ${STAGEDIR}${EXAMPLESDIR}/dot.motd.sample
+ ${INSTALL_DATA} ${WRKSRC}/.players ${STAGEDIR}${EXAMPLESDIR}/dot.players.sample
+ ${INSTALL_DATA} ${WRKSRC}/.server_defaults ${STAGEDIR}${EXAMPLESDIR}/dot.server_defaults.sample
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ANTIPOLIX_RULES CLIENT_USE COPYRIGHT SERVER_USE
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/antipolix
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/games/antipolix/pkg-plist b/games/antipolix/pkg-plist
index 01e85648f02f..f77a3eb540e0 100644
--- a/games/antipolix/pkg-plist
+++ b/games/antipolix/pkg-plist
@@ -1,11 +1,11 @@
bin/antipolix-client
bin/antipolix-server
-%%PORTDOCS%%share/doc/antipolix/ANTIPOLIX_RULES
-%%PORTDOCS%%share/doc/antipolix/CLIENT_USE
-%%PORTDOCS%%share/doc/antipolix/COPYRIGHT
-%%PORTDOCS%%share/doc/antipolix/SERVER_USE
-share/examples/antipolix/dot.motd.sample
-share/examples/antipolix/dot.players.sample
-share/examples/antipolix/dot.server_defaults.sample
-%%PORTDOCS%%@dirrm share/doc/antipolix
-@dirrm share/examples/antipolix
+%%PORTDOCS%%%%DOCSDIR%%/ANTIPOLIX_RULES
+%%PORTDOCS%%%%DOCSDIR%%/CLIENT_USE
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/SERVER_USE
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dot.motd.sample
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dot.players.sample
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dot.server_defaults.sample
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%