aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/bygfoot/Makefile2
-rw-r--r--games/corewars/Makefile2
-rw-r--r--games/crossfire-client/Makefile1
-rw-r--r--games/csmash/Makefile2
-rw-r--r--games/ggz-client-libs/Makefile1
-rw-r--r--games/ggz-gtk-client/Makefile2
-rw-r--r--games/ggz-gtk-games/Makefile2
-rw-r--r--games/ggz-txt-client/Makefile1
-rw-r--r--games/glaxium/Makefile1
-rw-r--r--games/gno3dtet/Makefile2
-rw-r--r--games/gnubg/Makefile2
-rw-r--r--games/gnurobots/Makefile2
-rw-r--r--games/gretools/Makefile2
-rw-r--r--games/gtetrinet/Makefile2
-rw-r--r--games/gtkballs/Makefile2
-rw-r--r--games/libggz/Makefile2
-rw-r--r--games/macopix/Makefile1
-rw-r--r--games/monkeybubble/Makefile2
-rw-r--r--games/monster-masher/Makefile2
-rw-r--r--games/rtb/Makefile2
-rw-r--r--games/senken/Makefile2
-rw-r--r--games/teg/Makefile2
-rw-r--r--games/wargus/Makefile2
-rw-r--r--games/wesnoth-devel/Makefile2
-rw-r--r--games/wesnoth/Makefile2
-rw-r--r--games/zoom/Makefile1
26 files changed, 20 insertions, 26 deletions
diff --git a/games/bygfoot/Makefile b/games/bygfoot/Makefile
index 07de1646b3ad..dba8aa4566bd 100644
--- a/games/bygfoot/Makefile
+++ b/games/bygfoot/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GNOME= gtk20 gnometarget
+USE_GNOME= gtk20
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.include <bsd.port.mk>
diff --git a/games/corewars/Makefile b/games/corewars/Makefile
index 38af0809e199..43c66037999d 100644
--- a/games/corewars/Makefile
+++ b/games/corewars/Makefile
@@ -16,7 +16,7 @@ COMMENT= A simulation game where the goal is to crash each other's programs
BUILD_DEPENDS= ${LOCALBASE}/lib/libargp.a:${PORTSDIR}/devel/argp-standalone
-USE_GNOME= gnometarget gtk12
+USE_GNOME= gtk12
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/games/crossfire-client/Makefile b/games/crossfire-client/Makefile
index 85e3f4a0cd3c..0fbac50e5209 100644
--- a/games/crossfire-client/Makefile
+++ b/games/crossfire-client/Makefile
@@ -23,7 +23,6 @@ COMMENT= Multiplayer graphical arcade and adventure game made for X11
USE_PERL5= yes
USE_XORG= xpm
WANT_GNOME= yes
-USE_GNOME= gnometarget
USE_GMAKE= yes
USE_SDL= image sdl
GNU_CONFIGURE= yes
diff --git a/games/csmash/Makefile b/games/csmash/Makefile
index e2a91ca6e68b..e21a99e17483 100644
--- a/games/csmash/Makefile
+++ b/games/csmash/Makefile
@@ -18,7 +18,7 @@ COMMENT= A 3D tabletennis game
USE_GETTEXT= yes
USE_SDL= image mixer sdl
USE_GL= yes
-USE_GNOME= gnometarget gtk20
+USE_GNOME= gtk20
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/SDL" \
diff --git a/games/ggz-client-libs/Makefile b/games/ggz-client-libs/Makefile
index a92dfbdbb4b5..db0358b3b7da 100644
--- a/games/ggz-client-libs/Makefile
+++ b/games/ggz-client-libs/Makefile
@@ -17,7 +17,6 @@ COMMENT= The GGZ Gaming Zone - Core Client Libraries
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libtool
-USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug --with-libggz-dir="${LOCALBASE}"
diff --git a/games/ggz-gtk-client/Makefile b/games/ggz-gtk-client/Makefile
index 07c95a0c6dae..eb8f96c3f706 100644
--- a/games/ggz-gtk-client/Makefile
+++ b/games/ggz-gtk-client/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= The GGZ Gaming Zone - GTK+ Frontend
USE_AUTOTOOLS= libtool
-USE_GNOME= gnometarget gtk20
+USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
diff --git a/games/ggz-gtk-games/Makefile b/games/ggz-gtk-games/Makefile
index 8f8192c2a859..57863c75ac68 100644
--- a/games/ggz-gtk-games/Makefile
+++ b/games/ggz-gtk-games/Makefile
@@ -16,7 +16,7 @@ COMMENT= The GGZ Gaming Zone - GTK+ Games
RUN_DEPENDS= ${LOCALBASE}/bin/ggz-gtk:${PORTSDIR}/games/ggz-gtk-client
-USE_GNOME= gnometarget gtk20
+USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
diff --git a/games/ggz-txt-client/Makefile b/games/ggz-txt-client/Makefile
index 07aee03b3c50..9331a5c833ee 100644
--- a/games/ggz-txt-client/Makefile
+++ b/games/ggz-txt-client/Makefile
@@ -14,7 +14,6 @@ CATEGORIES= games
MAINTAINER= kde@FreeBSD.org
COMMENT= The GGZ Gaming Zone - Console (Text) Frontend
-USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
diff --git a/games/glaxium/Makefile b/games/glaxium/Makefile
index 65124d71e51f..a38fa2392e05 100644
--- a/games/glaxium/Makefile
+++ b/games/glaxium/Makefile
@@ -17,7 +17,6 @@ COMMENT= An OpenGL based space-ship "shoot-em-up" game
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
-USE_GNOME= gnometarget
USE_SDL= sdl mixer
USE_GL= glut
USE_GMAKE= yes
diff --git a/games/gno3dtet/Makefile b/games/gno3dtet/Makefile
index 82f800cb50ab..c3bf187cb32f 100644
--- a/games/gno3dtet/Makefile
+++ b/games/gno3dtet/Makefile
@@ -17,7 +17,7 @@ COMMENT= GNOME version of the classic 3D-ified T*tris
EXTRACT_DEPENDS=intltoolize:${PORTSDIR}/textproc/intltool
-USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui librsvg2
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui librsvg2
USE_GMAKE= yes
USE_AUTOTOOLS= autoheader automake aclocal autoconf
ACLOCAL_ARGS= -I m4 -I ${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index 33ff9f231f1d..78e139647bb2 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -35,7 +35,7 @@ CONFIGURE_ARGS= --with-board3d
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
ac_cv_path_ARTSC_CONFIG=no ac_cv_path_LIBART_CONFIG=no
-USE_GNOME= gnomehack gnometarget libxml2
+USE_GNOME= gnomehack libxml2
USE_GMAKE= yes
USE_PYTHON= 2.0+
USE_AUTOTOOLS= libtool automake
diff --git a/games/gnurobots/Makefile b/games/gnurobots/Makefile
index 40da7ed28477..b7f15eadb739 100644
--- a/games/gnurobots/Makefile
+++ b/games/gnurobots/Makefile
@@ -16,7 +16,7 @@ COMMENT= GNU diversion wherein Scheme-coded robots explore a world
LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile
-USE_GNOME= gnometarget vte
+USE_GNOME= vte
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/games/gretools/Makefile b/games/gretools/Makefile
index 46e5f5ab0f2e..653b03b39e01 100644
--- a/games/gretools/Makefile
+++ b/games/gretools/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTVERSION:R}
MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME vocabulary builder
-USE_GNOME= gnomehack gnomeprefix gnometarget pygnome2
+USE_GNOME= gnomehack gnomeprefix pygnome2
USE_PYTHON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/games/gtetrinet/Makefile b/games/gtetrinet/Makefile
index f39b5074f87c..708be970eb70 100644
--- a/games/gtetrinet/Makefile
+++ b/games/gtetrinet/Makefile
@@ -16,7 +16,7 @@ COMMENT= A version of the popular TetriNET multiplayer tetris clone
USE_GETTEXT= yes
USE_BZIP2= yes
-USE_GNOME= esound gnomehack gnomeprefix gnometarget libgnomeui
+USE_GNOME= esound gnomehack gnomeprefix libgnomeui
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/games/gtkballs/Makefile b/games/gtkballs/Makefile
index fbd22e9b5a76..4669b4610bef 100644
--- a/games/gtkballs/Makefile
+++ b/games/gtkballs/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Lines-like simple logic game for X Window System
USE_GETTEXT= yes
-USE_GNOME= gnometarget gtk20
+USE_GNOME= gtk20
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/games/libggz/Makefile b/games/libggz/Makefile
index ce304d6ea36c..032e83b6663e 100644
--- a/games/libggz/Makefile
+++ b/games/libggz/Makefile
@@ -17,7 +17,7 @@ COMMENT= The GGZ Gaming Zone - Base Library
LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack gnometarget
+USE_GNOME= gnomehack
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
diff --git a/games/macopix/Makefile b/games/macopix/Makefile
index 02c16c2bf12d..a511e62e3a9b 100644
--- a/games/macopix/Makefile
+++ b/games/macopix/Makefile
@@ -33,7 +33,6 @@ RESTRICTED_FILES= \
macopix-mascot-marimite-euc-ja-2.20.tar.gz \
macopix-mascot-HxB-euc-ja-0.30.tar.gz
-USE_GNOME= gnometarget
WANT_GNOME= yes
USE_GETTEXT= yes
USE_GMAKE= yes
diff --git a/games/monkeybubble/Makefile b/games/monkeybubble/Makefile
index b21a493bc773..60033a3eb865 100644
--- a/games/monkeybubble/Makefile
+++ b/games/monkeybubble/Makefile
@@ -15,7 +15,7 @@ DISTNAME= monkey-bubble-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK2 Puzzle Bobble clone with monkeys
-USE_GNOME= gnomedocutils gnomehack gnomeprefix gnometarget intlhack \
+USE_GNOME= gnomedocutils gnomehack gnomeprefix intlhack \
librsvg2 libgnomeui
USE_GSTREAMER= yes
USE_GMAKE= yes
diff --git a/games/monster-masher/Makefile b/games/monster-masher/Makefile
index c3f80761f41e..b6ec57736385 100644
--- a/games/monster-masher/Makefile
+++ b/games/monster-masher/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= gnomecanvasmm-2.6.1:${PORTSDIR}/graphics/libgnomecanvasmm26 \
glademm-2.4.1:${PORTSDIR}/devel/libglademm24
USE_BZIP2= yes
-USE_GNOME= gnomeprefix gnomehack gnometarget intlhack libgnome esound
+USE_GNOME= gnomeprefix gnomehack intlhack libgnome esound
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index 1017435aef74..e66616b3e796 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -18,7 +18,7 @@ COMMENT= Robot programming game for UNIX
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
USE_BZIP2= yes
-USE_GNOME= gnometarget gtk20
+USE_GNOME= gtk20
USE_PERL5= yes
USE_PYTHON= yes
USE_GMAKE= yes
diff --git a/games/senken/Makefile b/games/senken/Makefile
index a834540b2ea9..b3969d584969 100644
--- a/games/senken/Makefile
+++ b/games/senken/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= ports@FreeBSD.org
COMMENT= A city simulation game
-USE_GNOME= gnometarget gtk20
+USE_GNOME= gtk20
USE_SDL= image sdl
GNU_CONFIGURE= yes
diff --git a/games/teg/Makefile b/games/teg/Makefile
index d9d0ac0335fe..b4b6dccfa32c 100644
--- a/games/teg/Makefile
+++ b/games/teg/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A turn-based strategy game for GNOME
-USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/games/wargus/Makefile b/games/wargus/Makefile
index 10f5976453be..0a3625e64353 100644
--- a/games/wargus/Makefile
+++ b/games/wargus/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= stratagus:${PORTSDIR}/games/stratagus
LICENSE= GPLv2
NOT_FOR_ARCHS= sparc64
USE_GMAKE= yes
-USE_GNOME= gtk20 gnomehack gnometarget
+USE_GNOME= gtk20 gnomehack
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SUB_FILES= ${PORTNAME} pkg-message
diff --git a/games/wesnoth-devel/Makefile b/games/wesnoth-devel/Makefile
index 48bb5e4e636a..cd73ae056f95 100644
--- a/games/wesnoth-devel/Makefile
+++ b/games/wesnoth-devel/Makefile
@@ -27,7 +27,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS= wesnoth-[0-9]*
USE_SDL= image mixer net ttf
-USE_GNOME= gnometarget pango
+USE_GNOME= pango
MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
USE_CMAKE= yes
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index bab318bd37a0..260f00ce760e 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -23,7 +23,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS= wesnoth-devel-[0-9]*
USE_SDL= image mixer net ttf
-USE_GNOME= gnometarget pango
+USE_GNOME= pango
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
diff --git a/games/zoom/Makefile b/games/zoom/Makefile
index 76cdb80b1c68..67fb99e2fa4d 100644
--- a/games/zoom/Makefile
+++ b/games/zoom/Makefile
@@ -21,7 +21,6 @@ LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
USE_CSTD= gnu89
USE_PERL5= yes
USE_XORG= xft
-USE_GNOME= gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \