aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/bomberinstinct/Makefile23
-rw-r--r--games/bomberinstinct/files/patch-src__main.c52
2 files changed, 61 insertions, 14 deletions
diff --git a/games/bomberinstinct/Makefile b/games/bomberinstinct/Makefile
index f0949862d37b..7315e5e5fbd7 100644
--- a/games/bomberinstinct/Makefile
+++ b/games/bomberinstinct/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bomberinstinct
-# Date created: 28 September 2000
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= bomberinstinct
PORTVERSION= 0.8.9
@@ -13,20 +9,19 @@ MASTER_SITES= SF/${PORTNAME}/Bomber%20Instinct/BomberInstinct-${PORTVERSION}
DISTNAME= BomberInstinct-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A nice Bomberman-like multiplayer game
+COMMENT= Bomberman-like multiplayer game
WRKSRC= ${WRKDIR}/${DISTNAME}
+USES= gettext gmake
USE_SDL= mixer sdl
-USES= gettext
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_PERL5_BUILD=yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl
-pre-patch:
- @${FIND} ${WRKSRC} -name "*.[ch]" | \
- ${XARGS} ${PERL} -pi -e 's|<SDL/|<|g'
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lintl -pthread
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<SDL/|<|g'
.include <bsd.port.mk>
diff --git a/games/bomberinstinct/files/patch-src__main.c b/games/bomberinstinct/files/patch-src__main.c
new file mode 100644
index 000000000000..963f0c2094f0
--- /dev/null
+++ b/games/bomberinstinct/files/patch-src__main.c
@@ -0,0 +1,52 @@
+--- src/main.c.orig
++++ src/main.c
+@@ -341,6 +341,24 @@
+ }
+
+
++/*--Rafraichir l'écran (à chaque frame), suivant le mode--*/
++void rafraichit(void)
++ {
++ if (dblebuf) {
++ SDL_Flip(ecran);
++ nrsrect=0;
++ nrs=!nrs;
++ }
++ else {
++ SDL_UpdateRects(ecran, nrsrect, rsrect);
++ nrsrect=0;
++ nrs=0;
++ }
++
++ return;
++}
++
++
+ /*--Affiche des informations, pose une question--*/
+ void dialogue(char * texte, int estunequestion)
+ {
+@@ -1176,24 +1194,6 @@
+ }
+
+
+-/*--Rafraichir l'écran (à chaque frame), suivant le mode--*/
+-int rafraichit(void)
+-{
+- if (dblebuf) {
+- SDL_Flip(ecran);
+- nrsrect=0;
+- nrs=!nrs;
+- }
+- else {
+- SDL_UpdateRects(ecran, nrsrect, rsrect);
+- nrsrect=0;
+- nrs=0;
+- }
+-
+- return;
+-}
+-
+-
+ /*--Dessine la jauge d'énergie du joueur n à droite de l'écran--*/
+ void jauge(int n)
+ {