aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/flobopuyo/Makefile8
-rw-r--r--games/kaid/Makefile8
-rw-r--r--games/noegnud-littlehack/Makefile8
-rw-r--r--games/noegnud-nethack-deet/Makefile8
-rw-r--r--games/noegnud-nethack/Makefile8
-rw-r--r--games/noegnud-slashem/Makefile8
-rw-r--r--games/quakeforge/Makefile50
-rw-r--r--games/stonesoup/Makefile8
-rw-r--r--games/warzone2100/Makefile2
-rw-r--r--games/windstille/Makefile8
10 files changed, 42 insertions, 74 deletions
diff --git a/games/flobopuyo/Makefile b/games/flobopuyo/Makefile
index 11c85b6ef205..55e666878a11 100644
--- a/games/flobopuyo/Makefile
+++ b/games/flobopuyo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: flobopuyo
-# Date created: 24 Feb 2006
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= flobopuyo
PORTVERSION= 0.20
@@ -16,7 +12,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Clone of the famous PuyoPuyo
-USE_BISON= build
+USES= bison
USE_GMAKE= yes
USE_SDL= sdl mixer image
MAKE_JOBS_SAFE= yes
diff --git a/games/kaid/Makefile b/games/kaid/Makefile
index fa1bdc590848..de954e919a9a 100644
--- a/games/kaid/Makefile
+++ b/games/kaid/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kaid
-# Date created: 18 Feb 2005
-# Whom: Sebastiaan van Erk
-#
+# Created by: Sebastiaan van Erk
# $FreeBSD$
-#
PORTNAME= kaid
PORTVERSION= 7.0.0.4b
@@ -19,7 +15,7 @@ COMMENT= XLink Kai tunneling server
NO_WRKSUBDIR= yes
USE_GMAKE= yes
-USE_BISON= build
+USES= bison
USE_ZIP= yes
CC= gcc
CPP= g++
diff --git a/games/noegnud-littlehack/Makefile b/games/noegnud-littlehack/Makefile
index d2a2e3138435..09c4922be8f1 100644
--- a/games/noegnud-littlehack/Makefile
+++ b/games/noegnud-littlehack/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: noegnud-littlehack
-# Date created: 7 April 2004
-# Whom: Leland Wang <llwang@infor.org>
-#
+# Created by: Leland Wang <llwang@infor.org>
# $FreeBSD$
-#
PORTNAME= noegnud
PORTVERSION= 0.8.3
@@ -22,7 +18,7 @@ COMMENT= The noeGNUd UI for the LittleHack variation of Nethack
RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
-USE_BISON= build
+USES= bison
USE_GL= yes
WANT_SDL= yes
USE_SDL= sdl image mixer
diff --git a/games/noegnud-nethack-deet/Makefile b/games/noegnud-nethack-deet/Makefile
index 94f3e3396e13..bd7ba2aa99f0 100644
--- a/games/noegnud-nethack-deet/Makefile
+++ b/games/noegnud-nethack-deet/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: noegnud-nethack-deet
-# Date created: 7 April 2004
-# Whom: Leland Wang <llwang@infor.org>
-#
+# Created by: Leland Wang <llwang@infor.org>
# $FreeBSD$
-#
PORTNAME= noegnud
PORTVERSION= 0.8.3
@@ -22,7 +18,7 @@ COMMENT= The noeGNUd UI for Nethack with DeeT's hack font patch
RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
-USE_BISON= build
+USES= bison
USE_GL= yes
WANT_SDL= yes
USE_SDL= sdl image mixer
diff --git a/games/noegnud-nethack/Makefile b/games/noegnud-nethack/Makefile
index 3c62f8e34845..5a81abe811b3 100644
--- a/games/noegnud-nethack/Makefile
+++ b/games/noegnud-nethack/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: noegnud-nethack
-# Date created: 7 April 2004
-# Whom: Leland Wang <llwang@infor.org>
-#
+# Created by: Leland Wang <llwang@infor.org>
# $FreeBSD$
-#
PORTNAME= noegnud
PORTVERSION= 0.8.3
@@ -22,7 +18,7 @@ COMMENT= The noeGNUd UI for the vanilla Nethack
RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
-USE_BISON= build
+USES= bison
USE_GL= yes
WANT_SDL= yes
USE_SDL= sdl image mixer
diff --git a/games/noegnud-slashem/Makefile b/games/noegnud-slashem/Makefile
index 28220b0e36ee..238e7768b193 100644
--- a/games/noegnud-slashem/Makefile
+++ b/games/noegnud-slashem/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: noegnud-slashem
-# Date created: 7 April 2004
-# Whom: Leland Wang <llwang@infor.org>
-#
+# Created by: Leland Wang <llwang@infor.org>
# $FreeBSD$
-#
PORTNAME= noegnud
PORTVERSION= 0.8.3
@@ -22,7 +18,7 @@ COMMENT= The noeGNUd UI for the SLASH'EM variant of Nethack
RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
-USE_BISON= build
+USES= bison
USE_GL= yes
WANT_SDL= yes
USE_SDL= sdl image mixer
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index ccbe61001acc..6e8534fa8c34 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: QuakeForge
-# Date created: 4 January 2000
-# Whom: darius@dons.net.au
-#
+# Created by: darius@dons.net.au
# $FreeBSD$
-#
PORTNAME= quakeforge
PORTVERSION= 0.5.5
@@ -21,7 +17,7 @@ NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON= generated Quake C compiler (qfcc) does not work
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USE_BISON= build
+USES= bison
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -31,13 +27,17 @@ CONFIGURE_ARGS+=--with-global-cfg=${PREFIX}/etc/quakeforge.conf \
--with-sharepath=${DATADIR} \
--disable-optimize
-OPTIONS= CLIENTS "Build clients" on \
- OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- SDL "Build SDL client" off \
- SERVERS "Build dedicated servers" on \
- SKYBOXES "Install skyboxes pak" off \
- VORBIS "Enable Ogg Vorbis support in clients" off \
- XMMS "Enable XMMS support in clients" off
+OPTIONS_DEFINE= CLIENTS OPTIMIZED_CFLAGS SDL SERVERS SKYBOXES VORBIS \
+ XMMS DOCS
+
+OPTIONS_DEFAULT= CLIENTS OPTIMIZED_CFLAGS SERVERS DOCS
+
+CLIENTS_DESC= Clients
+SDL_DESC= SDL client
+SERVERS_DESC= Dedicated servers
+SKYBOXES_DESC= Install skyboxes pak
+VORBIS_DESC= Ogg Vorbis support in clients
+XMMS_DESC= XMMS support in clients
MAN1= pak.1 qfcc.1 qflight.1 qfvis.1 wad.1
SUB_FILES= pkg-message
@@ -46,14 +46,14 @@ DATADIR= ${Q1DIR}
.include "${.CURDIR}/../quake-data/Makefile.include"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_CLIENTS)
+.if ${PORT_OPTIONS:MCLIENTS}
USE_GL= yes
USE_XORG= x11 xt
PLIST_SUB+= CLIENTS=""
-.if defined(WITH_SDL)
+.if ${PORT_OPTIONS:MSDL}
USE_SDL= sdl
CONFIGURE_ARGS+=--with-sdl=${LOCALBASE}
PLIST_SUB+= SDL=""
@@ -62,7 +62,7 @@ CONFIGURE_ARGS+=--disable-sdl
PLIST_SUB+= SDL="@comment "
.endif
-.if defined(WITH_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+=--with-ogg=${LOCALBASE} --with-vorbis=${LOCALBASE}
PLIST_SUB+= VORBIS=""
@@ -71,7 +71,7 @@ CONFIGURE_ARGS+=--disable-ogg --disable-vorbis
PLIST_SUB+= VORBIS="@comment "
.endif
-.if defined(WITH_XMMS)
+.if ${PORT_OPTIONS:MXMMS}
LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
CONFIGURE_ARGS+=--with-xmms-prefix=${LOCALBASE}
PLIST_SUB+= XMMS=""
@@ -83,9 +83,9 @@ PLIST_SUB+= XMMS="@comment "
.else
CONFIGURE_ARGS+=--with-clients=""
PLIST_SUB+= CLIENTS="@comment "
-.endif # WITH_CLIENTS
+.endif
-.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -O3 -funroll-loops -fomit-frame-pointer -fno-common \
-fexpensive-optimizations -fstrict-aliasing
. if ${ARCH} != "alpha"
@@ -93,14 +93,14 @@ CFLAGS+= -ffast-math
. endif
.endif
-.if !defined(WITHOUT_SERVERS)
+.if ${PORT_OPTIONS:MSERVERS}
PLIST_SUB+= SERVERS=""
.else
CONFIGURE_ARGS+=--with-servers=""
PLIST_SUB+= SERVERS="@comment "
.endif
-.if defined(WITH_SKYBOXES)
+.if ${PORT_OPTIONS:MSKYBOXES}
MASTER_SITES+= http://www.quakeforge.net/files/:qf
DISTFILES+= skyboxes.pak:qf
PLIST_SUB+= SKYBOXES=""
@@ -109,10 +109,10 @@ PLIST_SUB+= SKYBOXES="@comment "
.endif
post-install:
-.if defined(WITH_SKYBOXES)
+.if ${PORT_OPTIONS:MSKYBOXES}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/skyboxes.pak ${DATADIR}/QF
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for f in *.txt *.q1 *.q2 *.ico *.gif *.fig *.h CodingStyle
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
@@ -123,4 +123,4 @@ post-install:
.endif
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 8ecc8d94e250..fa8c30f742fc 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dcss
-# Date created: 2008-07-11
-# Whom: Tobias Rehbein <tobias.rehbein@web.de>
-#
+# Created by: Tobias Rehbein <tobias.rehbein@web.de>
# $FreeBSD$
-#
PORTNAME= stonesoup
PORTVERSION= 0.11.1
@@ -19,7 +15,7 @@ LICENSE_FILE= ${WRKDIR}/stone_soup-${PORTVERSION}/licence.txt
USE_SQLITE= yes
USE_XZ= yes
-USE_BISON= build
+USES= bison
USE_GMAKE= yes
USE_LUA= 5.1
USE_PERL5_BUILD= yes
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index 6d4de6481c7b..44445ec8720b 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= physfs:${PORTSDIR}/devel/physfs \
RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
USE_XZ= yes
-USE_BISON= build
+USES= bison
GNU_CONFIGURE= yes
USE_OPENAL= al
USE_GL= yes
diff --git a/games/windstille/Makefile b/games/windstille/Makefile
index a625481e8f5c..1cc4dccb49e4 100644
--- a/games/windstille/Makefile
+++ b/games/windstille/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: windstille
-# Date created: 14 Jun 2007
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= windstille
PORTVERSION= 0.3.0
@@ -27,7 +23,7 @@ USE_SCONS= yes
USE_OPENAL= al
USE_GL= glew
USE_SDL= sdl image
-USE_BISON= build
+USES= bison
MAKE_JOBS_SAFE= yes
post-extract: