aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/gnake/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/games/gnake/Makefile b/games/gnake/Makefile
index 24b4718de952..930ebc99b3ce 100644
--- a/games/gnake/Makefile
+++ b/games/gnake/Makefile
@@ -4,19 +4,21 @@
PORTNAME= gnake
PORTVERSION= 0.94b
CATEGORIES= games
-MASTER_SITES= LOCAL/chinsan \
- http://lightless.org/files/
+MASTER_SITES= http://lightless.org/files/ \
+ LOCAL/jgh/games/${PORTNAME}/
DISTNAME= Gnake.${PORTVERSION}
MAINTAINER= jgh@FreeBSD.org
COMMENT= Nibbles clone for GNU/Linux and *BSD
LICENSE= GPLv2
+
+OPTIONS_DEFINE= DOCS
+
LDFLAGS+= -L${LOCALBASE}/lib -lncurses
CFLAGS+= -Wall
WRKSRC= ${WRKDIR}/${PORTNAME}
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
PORTDOCS= README
PLIST_FILES= bin/${PORTNAME}
@@ -24,11 +26,13 @@ do-build:
${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/${PORTNAME} \
${WRKSRC}/gnake.c
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>