aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/capitalism/Makefile5
-rw-r--r--games/gnome-games/Makefile3
-rw-r--r--games/klavaro/Makefile5
-rw-r--r--games/spellathon/Makefile5
4 files changed, 8 insertions, 10 deletions
diff --git a/games/capitalism/Makefile b/games/capitalism/Makefile
index ab295af440c0..32b6a2ef68ad 100644
--- a/games/capitalism/Makefile
+++ b/games/capitalism/Makefile
@@ -18,13 +18,12 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- xcb:${PORTSDIR}/x11/libxcb
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
WRKSRC= ${WRKDIR}/Capitalism-${PORTVERSION}
USES= iconv
-USE_XORG= ice sm x11 xau xdmcp xext xrender
+USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
USE_QT4= moc_build qmake_build rcc_build uic_build iconengines imageformats \
corelib gui network script xml
MAKE_JOBS_SAFE= yes
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index 472e1a386c36..d45af14848d7 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gnome-games
PORTVERSION= 2.32.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -25,6 +25,7 @@ USE_PYTHON= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_GMAKE= yes
+USE_GL= gl
USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack librsvg2 desktopfileutils \
pygnomedesktop gnomedocutils
diff --git a/games/klavaro/Makefile b/games/klavaro/Makefile
index 9fedf73ce24a..87bd222bb921 100644
--- a/games/klavaro/Makefile
+++ b/games/klavaro/Makefile
@@ -19,13 +19,12 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- gtkdatabox:${PORTSDIR}/x11-toolkits/gtkdatabox \
- xcb:${PORTSDIR}/x11/libxcb
+ gtkdatabox:${PORTSDIR}/x11-toolkits/gtkdatabox
USES= pkgconfig gettext iconv
USE_BZIP2= yes
USE_GMAKE= yes
-USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext \
+USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xrandr xrender
USE_GNOME= gtk20
USE_LDCONFIG= yes
diff --git a/games/spellathon/Makefile b/games/spellathon/Makefile
index 3b8c885cbf61..a84e1ef4a8d7 100644
--- a/games/spellathon/Makefile
+++ b/games/spellathon/Makefile
@@ -17,14 +17,13 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
png15:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2 \
expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- xcb:${PORTSDIR}/x11/libxcb
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
CXXFLAGS+= -fPIC
USES= gettext iconv
USE_GNOME= glib20
USE_QT4= corelib gui moc_build qmake_build rcc_build uic_build
-USE_XORG= ice sm x11 xau xdmcp xext xrender
+USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes