aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/quake2-relay/Makefile30
-rw-r--r--games/quake2-relay/pkg-descr2
-rw-r--r--games/quake2-relay/pkg-plist9
3 files changed, 20 insertions, 21 deletions
diff --git a/games/quake2-relay/Makefile b/games/quake2-relay/Makefile
index 7f4ecc40f594..04aae9293b7d 100644
--- a/games/quake2-relay/Makefile
+++ b/games/quake2-relay/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Q2 Relay
-# Date created: 23 Mar 2006
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= relay
PORTVERSION= 0.4
@@ -16,22 +12,20 @@ DISTNAME= relay-${PORTVERSION}.src
MAINTAINER= danfe@FreeBSD.org
COMMENT= Quake II multi-view demo recording facility
+LICENSE= GPLv2
+
USE_GMAKE= yes
MAKE_ARGS= MODE=release OBJ_DIR=. OUT_DIR=. Q2MODULE=game.so \
QUAKE2_DIR="${Q2DIR}" BIN_DIR="${PREFIX}/bin" \
CC="${CC}" CFLAGS="${CFLAGS}"
WRKSRC= ${WRKDIR}/relay-${PORTVERSION}
-
-PLIST_FILES= bin/democonv bin/dm2server \
- %%Q2DIR%%/release/game.so \
- %%Q2DIR%%/proxy/relay/game.so \
- %%Q2DIR%%/proxy/replay/game.so
-PLIST_DIRS= %%Q2DIR%%/proxy/replay %%Q2DIR%%/proxy/relay \
- %%Q2DIR%%/proxy %%Q2DIR%%/release
PORTDOCS= FAQ README
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS
+
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+.include <bsd.port.options.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
CFLAGS+= -fPIC
@@ -45,18 +39,16 @@ post-patch: .SILENT
${WRKSRC}/common/mem.c
cd ${WRKSRC}/common && ${SH} -c 'for i in *.h; do \
${ECHO_CMD} >> $${i}; done'
- # Reorganize #include's (use /bin/ed to avoid a patch)
+# Reorganize #include's (use /bin/ed to avoid a patch)
${ECHO_CMD} -e '35t30\n36d\nwq' | ${ED} -s ${WRKSRC}/common/net.h
${ECHO_CMD} -e '9t7\n10d\nwq' | ${ED} -s ${WRKSRC}/common/net.c
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/FAQ ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
ED?= /bin/ed
-.include "${.CURDIR}/../quake2-data/Makefile.include"
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/quake2-relay/pkg-descr b/games/quake2-relay/pkg-descr
index f967e749c3f2..0851aa7b758a 100644
--- a/games/quake2-relay/pkg-descr
+++ b/games/quake2-relay/pkg-descr
@@ -13,5 +13,3 @@ Benefits of Relay:
- No lag
- Smaller and easier than many separate demos
- Many different viewing options
-
-WWW: http://www.planetquake.com/relay/
diff --git a/games/quake2-relay/pkg-plist b/games/quake2-relay/pkg-plist
new file mode 100644
index 000000000000..4046ded55e37
--- /dev/null
+++ b/games/quake2-relay/pkg-plist
@@ -0,0 +1,9 @@
+bin/democonv
+bin/dm2server
+%%Q2DIR%%/release/game.so
+%%Q2DIR%%/proxy/relay/game.so
+%%Q2DIR%%/proxy/replay/game.so
+@dirrm %%Q2DIR%%/proxy/replay
+@dirrm %%Q2DIR%%/proxy/relay
+@dirrm %%Q2DIR%%/proxy
+@dirrm %%Q2DIR%%/release