aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/rubix/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/rubix/Makefile b/games/rubix/Makefile
index e30a76597c2c..c1b789348949 100644
--- a/games/rubix/Makefile
+++ b/games/rubix/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rubix
-# Date created: 19 Nov 1999
-# Whom: Will Andrews <andrews@technologist.com>
-#
+# Created by: Will Andrews <andrews@technologist.com>
# $FreeBSD$
-#
PORTNAME= rubix
PORTVERSION= 1.0.6
@@ -20,15 +16,18 @@ USE_XORG= x11
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DENGLISH" \
XINC="-I${LOCALBASE}/include" XLIB="-L${LOCALBASE}/lib -lX11"
ALL_TARGET= ${PORTNAME}
+USE_GCC= any
PORTDOCS= ${DOCFILES}
PLIST_FILES= bin/rubix
DOCFILES= AUTHORS BUGS INSTALL README TODO
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rubix ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${DOCFILES}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
| | | | | | | | | | | | | | | With commits from avilla@, makc@, rakuco@ and Schaich Alonso. The upstream announcement can be found in [1]. [1] http://www.kde.org/announcements/announce-4.10.4.php clang support should be more stable now, with clang being recognized by kdelibs4 and being passed the correct flags to build other ports. Additionally, all ports being committed have been verified to build with -CURRENT's clang 3.3 on an amd64 tinderbox (special thanks go to swills@ for providing it). Work on the newly-released 4.10.5 will begin shortly. * KDE/FreeBSD team presents KDE SC 4.10.3 ports!makc2013-05-191-2/+2 | | | | | | - Remove patches and checks for unsupported FreeBSD versions. The area51 repository features commits by avilla, rakuco and myself. * KDE/FreeBSD team presents KDE SC 4.10.1 ports!makc2013-03-272-4/+4 | | | | | | | | | | | | | | | | | | | | | | | - kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner * Mk/bsd.kde4.mk:makc2013-03-221-1/+1 | | | | | | | | | | - Don't set CMAKE_BUILD_TYPE for debug builds (cmake.mk already handles it) - Don't set WITH_DEBUG for unstable branch (KDE4_BRANCH) - Remove now useless KDE4_BUILDENV KDE SC ports: - Chase KDE4_BUILDENV removal: replace 'KDE4_BUILDENV= yes' with 'USES= cmake:outsource' and add USE_LDCONFIG if needed * KDE/FreeBSD team presents KDE SC 4.9.5 ports!makc2013-02-04