aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/p5-Games-Bingo-Bot/Makefile3
-rw-r--r--games/p5-Games-Bingo-Print/Makefile3
-rw-r--r--games/p5-Games-Bingo/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/games/p5-Games-Bingo-Bot/Makefile b/games/p5-Games-Bingo-Bot/Makefile
index 0b7bbc1f68fc..494ea00e056d 100644
--- a/games/p5-Games-Bingo-Bot/Makefile
+++ b/games/p5-Games-Bingo-Bot/Makefile
@@ -17,7 +17,8 @@ COMMENT= A simple class holding IRC related methods for bingo
BUILD_DEPENDS= p5-Games-Bingo>=0:${PORTSDIR}/games/p5-Games-Bingo
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Games::Bingo::Bot.3
diff --git a/games/p5-Games-Bingo-Print/Makefile b/games/p5-Games-Bingo-Print/Makefile
index 8d5c56d41359..d5fb47275eff 100644
--- a/games/p5-Games-Bingo-Print/Makefile
+++ b/games/p5-Games-Bingo-Print/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-Games-Bingo>=0:${PORTSDIR}/games/p5-Games-Bingo \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= bingo_print.pl.1
MAN3= Games::Bingo::Print.3
diff --git a/games/p5-Games-Bingo/Makefile b/games/p5-Games-Bingo/Makefile
index 8d4347c33413..60a4021d450e 100644
--- a/games/p5-Games-Bingo/Makefile
+++ b/games/p5-Games-Bingo/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= A bingo game Perl implementation
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= bingo.pl.1
MAN3= Games::Bingo.3 \