aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/concentration/Makefile9
-rw-r--r--games/concentration/files/patch-src-concentration.c11
-rw-r--r--games/concentration/files/patch-src__sound.c17
3 files changed, 12 insertions, 25 deletions
diff --git a/games/concentration/Makefile b/games/concentration/Makefile
index 523ca5fe66d2..74bf3cddda29 100644
--- a/games/concentration/Makefile
+++ b/games/concentration/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: concentration
-# Date created: 10 Nov 2005
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= concentration
PORTVERSION= 1.2
@@ -24,7 +20,4 @@ LDFLAGS+= `${SDL_CONFIG} --libs`
MAN6= concentration.6
-post-patch:
- @${REINPLACE_CMD} -e 's|-std=gnu99 ||g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/games/concentration/files/patch-src-concentration.c b/games/concentration/files/patch-src-concentration.c
new file mode 100644
index 000000000000..896799b2a021
--- /dev/null
+++ b/games/concentration/files/patch-src-concentration.c
@@ -0,0 +1,11 @@
+--- src/concentration.c.orig 2005-11-09 19:05:02.000000000 +0300
++++ src/concentration.c 2013-06-04 07:00:25.084319599 +0400
+@@ -202,7 +202,7 @@
+
+ /*****************************************************
+ ****************************************************/
+-inline void drawText(char * str, SDL_Color color, int x, int y, TTF_Font * font)
++static inline void drawText(char * str, SDL_Color color, int x, int y, TTF_Font * font)
+ {
+ static SDL_Rect dest;
+
diff --git a/games/concentration/files/patch-src__sound.c b/games/concentration/files/patch-src__sound.c
deleted file mode 100644
index 52e4196c9eca..000000000000
--- a/games/concentration/files/patch-src__sound.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/sound.c.orig Tue Sep 21 05:08:59 2004
-+++ src/sound.c Thu Nov 10 05:06:02 2005
-@@ -47,12 +47,13 @@
- Mix_Chunk * loadSound(const char * name)
- {
- Mix_Chunk * temp;
-+ char * newname;
- int len1 = strlen(sg_data_path), len2 = strlen(name);
-
- if(disabled)
- return NULL;
-
-- char * newname = (char*)malloc(len1 + len2 + 1);
-+ newname = (char*)malloc(len1 + len2 + 1);
- if(newname == NULL) {
- fprintf(stderr, "Out of memory!\n");
- exit(1);