aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/crack-attack/Makefile3
-rw-r--r--games/crack-attack/files/patch-src__Attack.cxx10
-rw-r--r--games/crack-attack/pkg-plist1
3 files changed, 11 insertions, 3 deletions
diff --git a/games/crack-attack/Makefile b/games/crack-attack/Makefile
index f7b06e02112b..24948efe4553 100644
--- a/games/crack-attack/Makefile
+++ b/games/crack-attack/Makefile
@@ -18,9 +18,6 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-MAN6= crack-attack.6
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|#ifndef max|#if 0|' ${WRKSRC}/src/Game.h
diff --git a/games/crack-attack/files/patch-src__Attack.cxx b/games/crack-attack/files/patch-src__Attack.cxx
new file mode 100644
index 000000000000..07c74da2566b
--- /dev/null
+++ b/games/crack-attack/files/patch-src__Attack.cxx
@@ -0,0 +1,10 @@
+--- ./src/Attack.cxx.orig 2013-10-30 16:09:58.000000000 -0200
++++ ./src/Attack.cxx 2013-10-30 16:10:20.000000000 -0200
+@@ -84,6 +84,7 @@
+
+ player_name[0] = '\0';
+ parseCommandLine(argc, argv, mode, port, host_name, player_name, height, width);
++ glutInit(&argc, argv);
+ run_crack_attack(mode, port, host_name, player_name, height, width);
+
+ return 0;
diff --git a/games/crack-attack/pkg-plist b/games/crack-attack/pkg-plist
index aefa96d2acc6..7653b9acd255 100644
--- a/games/crack-attack/pkg-plist
+++ b/games/crack-attack/pkg-plist
@@ -1,4 +1,5 @@
bin/crack-attack
+man/man6/crack-attack.6.gz
%%DATADIR%%/clock_0.tga
%%DATADIR%%/clock_1.tga
%%DATADIR%%/clock_2.tga