aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/adgali/Makefile3
-rw-r--r--games/powerpak/files/Makefile.FreeBSD2
2 files changed, 3 insertions, 2 deletions
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index eee405cf8c55..10f27b648154 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -28,7 +28,8 @@ USE_GMAKE= yes
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_ENV= SDL_CONFIG=${SDL_CONFIG} \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include/freetype1 \
+ -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-compile-type=optim
INSTALLS_SHLIB= yes
diff --git a/games/powerpak/files/Makefile.FreeBSD b/games/powerpak/files/Makefile.FreeBSD
index 36d93f9b984c..01a4c21eb80f 100644
--- a/games/powerpak/files/Makefile.FreeBSD
+++ b/games/powerpak/files/Makefile.FreeBSD
@@ -1,6 +1,6 @@
CC?=gcc
LOCALBASE?=/usr/local
-CFLAGS+=-Wall -I${LOCALBASE}/include
+CFLAGS+=-Wall -I${LOCALBASE}/include/freetype1 -I${LOCALBASE}/include
LIBS=-L${LOCALBASE}/lib -lm -lSDL -lttf
OBJECTS=powerpak.o img.o img_gif.o img_ppm.o img_tif.o img_pcx.o img_bmp.o img_png.o img_jpg.o img_xxx.o \
PowerDraw/powerdraw.o PowerDraw/gfx.o PowerDraw/primitives.o PowerDraw/sprites.o PowerDraw/truetype.o \