aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/beret/Makefile48
-rw-r--r--games/beret/distinfo3
-rw-r--r--games/beret/files/patch-game.c11
-rw-r--r--games/beret/pkg-descr13
-rw-r--r--games/beret/pkg-plist128
6 files changed, 204 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 5131f6177bb3..cdbf6d3f9b4e 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -78,6 +78,7 @@
SUBDIR += battalion
SUBDIR += battletanks
SUBDIR += belooted
+ SUBDIR += beret
SUBDIR += billardgl
SUBDIR += biloba
SUBDIR += biniax2
diff --git a/games/beret/Makefile b/games/beret/Makefile
new file mode 100644
index 000000000000..949af6f3a7ea
--- /dev/null
+++ b/games/beret/Makefile
@@ -0,0 +1,48 @@
+# Created by: Alfonso S. Siciliano <alfix86@gmail.com>
+# $FreeBSD$
+
+PORTNAME= beret
+PORTVERSION= 1.2.1
+DISTVERSIONPREFIX= v
+CATEGORIES= games
+
+MAINTAINER= alfix86@gmail.com
+COMMENT= 2D puzzle-platformer game
+
+LICENSE= LGPL3
+
+RUN_DEPENDS= ${LOCALBASE}/share/fonts/averiagwf/AveriaSansGWF-Regular.ttf:x11-fonts/averiagwf
+
+USE_GITHUB= yes
+GH_ACCOUNT= alfonsosiciliano
+GH_PROJECT= beret-freebsd
+
+USE_SDL= sdl image ttf mixer
+MAKEFILE= BSDmakefile
+
+WORKINGSRC= ${WRKDIR}/${GH_PROJECT}-${PORTVERSION}
+DATADIR= ${PREFIX}/share/${PORTNAME}
+
+DESKTOP_ENTRIES="Beret" "" "beret" \
+ "beret" "" false
+
+PORTDOCS= README.txt
+
+FONT_DEP= AveriaSansGWF-Regular.ttf
+FONTDIR_DEP= ${LOCALBASE}/share/fonts/averiagwf
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/game.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WORKINGSRC}/beret ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WORKINGSRC} && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+.for datadir in images music rooms sfx
+ ${MKDIR} ${STAGEDIR}${DATADIR}/${datadir}
+ cd ${WORKINGSRC}/${datadir} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/${datadir}
+.endfor
+ cd ${STAGEDIR}${DATADIR} && ${LN} -s ${FONTDIR_DEP}/${FONT_DEP} ${FONT_DEP}
+
+.include <bsd.port.mk>
diff --git a/games/beret/distinfo b/games/beret/distinfo
new file mode 100644
index 000000000000..99cc09227ac3
--- /dev/null
+++ b/games/beret/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1491776962
+SHA256 (alfonsosiciliano-beret-freebsd-v1.2.1_GH0.tar.gz) = 05249f49cbe7bd81f586c5ba8a4ed6a5a1b399b4067d5ee7784acb777d44d474
+SIZE (alfonsosiciliano-beret-freebsd-v1.2.1_GH0.tar.gz) = 44732496
diff --git a/games/beret/files/patch-game.c b/games/beret/files/patch-game.c
new file mode 100644
index 000000000000..fc53985668ed
--- /dev/null
+++ b/games/beret/files/patch-game.c
@@ -0,0 +1,11 @@
+--- game.c.orig 2017-04-09 23:30:52 UTC
++++ game.c
+@@ -94,7 +94,7 @@
+ #elif defined __WIN32__
+ #define RESOURCE_PATH ""
+ #else
+-#define RESOURCE_PATH ""
++#define RESOURCE_PATH "%%PREFIX%%/share/beret/"
+ #endif
+ #endif
+
diff --git a/games/beret/pkg-descr b/games/beret/pkg-descr
new file mode 100644
index 000000000000..d29b7435bd4b
--- /dev/null
+++ b/games/beret/pkg-descr
@@ -0,0 +1,13 @@
+Beret is a 2D puzzle-platformer game about a scientist named Beret
+who has gained telekinetic abilities through his research at the
+Evil Corporation. He decides that the Evil Corporation is too evil
+for his liking, and begins his solitary quest to overthrow the
+corporation and punish the evil deeds of his employers.
+
+Beret has:
+- 21 puzzle-filled levels
+- 120 collectable Medallions
+- Over 20 hours of gameplay
+- An unlockable level editor
+
+WWW: http://kiwisauce.com/beret/
diff --git a/games/beret/pkg-plist b/games/beret/pkg-plist
new file mode 100644
index 000000000000..1bc889a1a1e8
--- /dev/null
+++ b/games/beret/pkg-plist
@@ -0,0 +1,128 @@
+bin/beret
+%%DATADIR%%/AveriaSansGWF-Regular.ttf
+%%DATADIR%%/images/bkg1.png
+%%DATADIR%%/images/bkg10.png
+%%DATADIR%%/images/bkg11.png
+%%DATADIR%%/images/bkg12.png
+%%DATADIR%%/images/bkg13.png
+%%DATADIR%%/images/bkg14.png
+%%DATADIR%%/images/bkg2.png
+%%DATADIR%%/images/bkg3.png
+%%DATADIR%%/images/bkg4.png
+%%DATADIR%%/images/bkg5.png
+%%DATADIR%%/images/bkg6.png
+%%DATADIR%%/images/bkg7.png
+%%DATADIR%%/images/bkg8.png
+%%DATADIR%%/images/bkg9.png
+%%DATADIR%%/images/block.bmp
+%%DATADIR%%/images/credits.png
+%%DATADIR%%/images/fade1.png
+%%DATADIR%%/images/fade2.png
+%%DATADIR%%/images/fade3.png
+%%DATADIR%%/images/fade4.png
+%%DATADIR%%/images/fade5.png
+%%DATADIR%%/images/gameselect.png
+%%DATADIR%%/images/getinput.png
+%%DATADIR%%/images/icon.ico
+%%DATADIR%%/images/inventory.png
+%%DATADIR%%/images/lvlnum.png
+%%DATADIR%%/images/mapbkg.png
+%%DATADIR%%/images/msg.png
+%%DATADIR%%/images/opt.png
+%%DATADIR%%/images/pit.png
+%%DATADIR%%/images/spritesheet.png
+%%DATADIR%%/images/teleguide.png
+%%DATADIR%%/images/tilesheet.png
+%%DATADIR%%/images/title.png
+%%DATADIR%%/music/beret0.ogg
+%%DATADIR%%/music/beret1.ogg
+%%DATADIR%%/music/beret10.ogg
+%%DATADIR%%/music/beret11.ogg
+%%DATADIR%%/music/beret12.ogg
+%%DATADIR%%/music/beret13.ogg
+%%DATADIR%%/music/beret2.ogg
+%%DATADIR%%/music/beret3.ogg
+%%DATADIR%%/music/beret4.ogg
+%%DATADIR%%/music/beret5.ogg
+%%DATADIR%%/music/beret6.ogg
+%%DATADIR%%/music/beret7.ogg
+%%DATADIR%%/music/beret8.ogg
+%%DATADIR%%/music/beret9.ogg
+%%DATADIR%%/rooms/maps
+%%DATADIR%%/rooms/metas
+%%DATADIR%%/rooms/rooms
+%%DATADIR%%/sfx/antimatter1.wav
+%%DATADIR%%/sfx/antimatter2.wav
+%%DATADIR%%/sfx/antimatter3.wav
+%%DATADIR%%/sfx/boom1.wav
+%%DATADIR%%/sfx/boom2.wav
+%%DATADIR%%/sfx/boom3.wav
+%%DATADIR%%/sfx/choice-beret1.wav
+%%DATADIR%%/sfx/choice-beret2.wav
+%%DATADIR%%/sfx/choice-beret3.wav
+%%DATADIR%%/sfx/choice-object1.wav
+%%DATADIR%%/sfx/choice-object2.wav
+%%DATADIR%%/sfx/choice-object3.wav
+%%DATADIR%%/sfx/clink.wav
+%%DATADIR%%/sfx/clink2.wav
+%%DATADIR%%/sfx/clink3.wav
+%%DATADIR%%/sfx/corner.wav
+%%DATADIR%%/sfx/crunch.wav
+%%DATADIR%%/sfx/crunch2.wav
+%%DATADIR%%/sfx/fake.wav
+%%DATADIR%%/sfx/fake2.wav
+%%DATADIR%%/sfx/frag1.wav
+%%DATADIR%%/sfx/frag2.wav
+%%DATADIR%%/sfx/frag3.wav
+%%DATADIR%%/sfx/frag4.wav
+%%DATADIR%%/sfx/frag5.wav
+%%DATADIR%%/sfx/frag6.wav
+%%DATADIR%%/sfx/hop1.wav
+%%DATADIR%%/sfx/hop2.wav
+%%DATADIR%%/sfx/hop3.wav
+%%DATADIR%%/sfx/infect.wav
+%%DATADIR%%/sfx/jump1.wav
+%%DATADIR%%/sfx/jump2.wav
+%%DATADIR%%/sfx/jump3.wav
+%%DATADIR%%/sfx/knock.wav
+%%DATADIR%%/sfx/knock2.wav
+%%DATADIR%%/sfx/knock3.wav
+%%DATADIR%%/sfx/med-b.wav
+%%DATADIR%%/sfx/med-g.wav
+%%DATADIR%%/sfx/med-o.wav
+%%DATADIR%%/sfx/med-p.wav
+%%DATADIR%%/sfx/med-r.wav
+%%DATADIR%%/sfx/med-w.wav
+%%DATADIR%%/sfx/platform1.wav
+%%DATADIR%%/sfx/platform2.wav
+%%DATADIR%%/sfx/platform3.wav
+%%DATADIR%%/sfx/pop.wav
+%%DATADIR%%/sfx/pop2.wav
+%%DATADIR%%/sfx/pop3.wav
+%%DATADIR%%/sfx/regen.wav
+%%DATADIR%%/sfx/regeninit.wav
+%%DATADIR%%/sfx/robo1.wav
+%%DATADIR%%/sfx/robo2.wav
+%%DATADIR%%/sfx/robo3.wav
+%%DATADIR%%/sfx/robo4.wav
+%%DATADIR%%/sfx/robo5.wav
+%%DATADIR%%/sfx/robo6.wav
+%%DATADIR%%/sfx/shot1.wav
+%%DATADIR%%/sfx/shot2.wav
+%%DATADIR%%/sfx/shot3.wav
+%%DATADIR%%/sfx/step1.wav
+%%DATADIR%%/sfx/step2.wav
+%%DATADIR%%/sfx/step3.wav
+%%DATADIR%%/sfx/stick.wav
+%%DATADIR%%/sfx/switch-gr1.wav
+%%DATADIR%%/sfx/switch-gr2.wav
+%%DATADIR%%/sfx/switch-gr3.wav
+%%DATADIR%%/sfx/switch-gv1.wav
+%%DATADIR%%/sfx/switch-gv2.wav
+%%DATADIR%%/sfx/switch-gv3.wav
+%%DATADIR%%/sfx/switch-rd1.wav
+%%DATADIR%%/sfx/switch-rd2.wav
+%%DATADIR%%/sfx/switch-rd3.wav
+%%DATADIR%%/sfx/tick1.wav
+%%DATADIR%%/sfx/tick2.wav
+%%DATADIR%%/sfx/tick3.wav