aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/avanor/Makefile3
-rw-r--r--games/balazar/Makefile3
-rw-r--r--games/bygfoot/Makefile3
-rw-r--r--games/cavezofphear/Makefile3
-rw-r--r--games/dungeoncrawl/Makefile3
-rw-r--r--games/eboard/Makefile3
-rw-r--r--games/evq3/Makefile3
-rw-r--r--games/excido/Makefile3
-rw-r--r--games/fmars/Makefile3
-rw-r--r--games/gnono/Makefile3
-rw-r--r--games/gtetrinet/Makefile3
-rw-r--r--games/jaggedalliance2/Makefile3
-rw-r--r--games/klavaro/Makefile3
-rw-r--r--games/lincity-ng/Makefile3
-rw-r--r--games/netradiant/Makefile3
-rw-r--r--games/nighthawk/Makefile3
-rw-r--r--games/qgo/Makefile3
-rw-r--r--games/quetoo/Makefile3
-rw-r--r--games/rtb/Makefile3
-rw-r--r--games/scid/Makefile3
-rw-r--r--games/sdlquake2/Makefile3
-rw-r--r--games/species/Makefile3
-rw-r--r--games/stepmania-devel/Makefile3
-rw-r--r--games/tomenet/Makefile3
-rw-r--r--games/tycho/Makefile3
-rw-r--r--games/ufoai/Makefile3
-rw-r--r--games/vdrift/Makefile3
-rw-r--r--games/wizznic/Makefile3
-rw-r--r--games/xpilot/Makefile3
29 files changed, 29 insertions, 58 deletions
diff --git a/games/avanor/Makefile b/games/avanor/Makefile
index 07082e6af8bb..7104b891001b 100644
--- a/games/avanor/Makefile
+++ b/games/avanor/Makefile
@@ -10,8 +10,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Rogue-like game with easy ADOM-like user interface
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
MAKE_ARGS+= VERSION=${PORTVERSION} DATA_DIR=${DATADIR}/
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/games/balazar/Makefile b/games/balazar/Makefile
index 949248f97796..913e9a9ee4c4 100644
--- a/games/balazar/Makefile
+++ b/games/balazar/Makefile
@@ -19,12 +19,11 @@ RUN_DEPENDS= soya_editor:${PORTSDIR}/graphics/py-soya3d \
${PYTHON_SITELIBDIR}/tofu/client.py:${PORTSDIR}/net/py-tofu \
${PYTHON_SITELIBDIR}/cerealizer/__init__.py:${PORTSDIR}/security/py-cerealizer
-USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_GL= glew
USE_SDL= sdl mixer
-USES= gettext twisted
+USES= gettext twisted tar:bzip2
PYDISTUTILS_PKGNAME= Balazar
PYDISTUTILS_EGGINFODIR= ${PREFIX}/share
diff --git a/games/bygfoot/Makefile b/games/bygfoot/Makefile
index dfc9189b320a..b8811024b0b3 100644
--- a/games/bygfoot/Makefile
+++ b/games/bygfoot/Makefile
@@ -15,9 +15,8 @@ COMMENT= Football (soccer) management game
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip
-USES= pkgconfig
+USES= pkgconfig tar:bzip2
GNU_CONFIGURE= yes
-USE_BZIP2= yes
USE_GNOME= gtk20
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lm
diff --git a/games/cavezofphear/Makefile b/games/cavezofphear/Makefile
index 4f0a8ad5f55b..67077517a89b 100644
--- a/games/cavezofphear/Makefile
+++ b/games/cavezofphear/Makefile
@@ -17,8 +17,7 @@ OPTIONS_DEFINE= DOCS
BUILD_WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
ALL_TARGET= phear
diff --git a/games/dungeoncrawl/Makefile b/games/dungeoncrawl/Makefile
index 4c8853d9585c..b8ce914ec3ef 100644
--- a/games/dungeoncrawl/Makefile
+++ b/games/dungeoncrawl/Makefile
@@ -14,8 +14,7 @@ COMMENT= Old school roguelike game
WRKSRC_SUBDIR= source
-USE_BZIP2= yes
-USES= ncurses
+USES= ncurses tar:bzip2
MAKEFILE= makefile.bsd
PORTDOCS= buglist.txt crawl.txt
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index 21eb48422563..23fd89fcb0fc 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -19,8 +19,7 @@ COMMENT= GTK+ chess board interface (mainly for FICS and chessd)
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
EXTRAS= 1pl2 2
-USES= shebangfix pkgconfig perl5
-USE_BZIP2= yes
+USES= shebangfix pkgconfig perl5 tar:bzip2
HAS_CONFIGURE= yes
USE_PERL5= build
USE_GNOME= gtk20
diff --git a/games/evq3/Makefile b/games/evq3/Makefile
index 0b6447a57985..c90ada220409 100644
--- a/games/evq3/Makefile
+++ b/games/evq3/Makefile
@@ -16,8 +16,7 @@ COMMENT= Marriage of XreaL and Icculus.org Q3 w/ Improvements
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
-USES= gmake dos2unix
-USE_BZIP2= yes
+USES= gmake dos2unix tar:bzip2
ALL_TARGET= release
WRKSRC= ${WRKDIR}/${PORTNAME}
CFLAGS+= -DMAP_ANONYMOUS=MAP_ANON
diff --git a/games/excido/Makefile b/games/excido/Makefile
index 6f07f980e56c..cfcabb3a0df6 100644
--- a/games/excido/Makefile
+++ b/games/excido/Makefile
@@ -19,10 +19,9 @@ LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_BZIP2= yes
USE_GL= yes
USE_SDL= image sdl ttf
-USES= gmake openal:al,alut
+USES= gmake openal:al,alut tar:bzip2
OPTIONS_DEFINE= DOCS
diff --git a/games/fmars/Makefile b/games/fmars/Makefile
index 5dcd91d42418..f22f57d269eb 100644
--- a/games/fmars/Makefile
+++ b/games/fmars/Makefile
@@ -14,8 +14,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= guile:${PORTSDIR}/lang/guile
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
ALL_TARGET= x${PORTNAME}
OPTIONS_DEFINE= DOCS OPTIMIZED_CFLAGS
diff --git a/games/gnono/Makefile b/games/gnono/Makefile
index 6df5a7034c94..defe3b305180 100644
--- a/games/gnono/Makefile
+++ b/games/gnono/Makefile
@@ -10,9 +10,8 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Uno card game
-USE_BZIP2= yes
USE_GNOME= gtk20 libgnomeui
-USES= gettext gmake pkgconfig
+USES= gettext gmake pkgconfig tar:bzip2
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/gtetrinet/Makefile b/games/gtetrinet/Makefile
index 6f8b2c889ef6..58b0bf415a05 100644
--- a/games/gtetrinet/Makefile
+++ b/games/gtetrinet/Makefile
@@ -11,8 +11,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= ports@FreeBSD.org
COMMENT= Version of the popular TetriNET multiplayer Tetris clone
-USE_BZIP2= yes
-USES= pathfix gettext gmake pkgconfig
+USES= pathfix gettext gmake pkgconfig tar:bzip2
USE_GNOME= esound gnomeprefix libgnomeui
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/jaggedalliance2/Makefile b/games/jaggedalliance2/Makefile
index 207aca2af1a3..2c5d27f18bca 100644
--- a/games/jaggedalliance2/Makefile
+++ b/games/jaggedalliance2/Makefile
@@ -16,8 +16,7 @@ DISTVERSIONSUFFIX= -source
# Ignore this if you feel adventurous
ONLY_FOR_ARCHS= amd64 arm i386 pc98
ONLY_FOR_ARCHS_REASON= Needs a little endian environment
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
USE_SDL= sdl
NO_CDROM= License only permits non-commerical use
NO_PACKAGE= Language of the datafiles must be hardcoded in the game binary
diff --git a/games/klavaro/Makefile b/games/klavaro/Makefile
index 8e30960012fd..e4b8a12add49 100644
--- a/games/klavaro/Makefile
+++ b/games/klavaro/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libgtkdatabox.so:${PORTSDIR}/x11-toolkits/gtkdatabox
-USES= pkgconfig gettext gmake iconv pathfix
-USE_BZIP2= yes
+USES= pkgconfig gettext gmake iconv pathfix tar:bzip2
USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xrandr xrender
USE_GNOME= gtk20
diff --git a/games/lincity-ng/Makefile b/games/lincity-ng/Makefile
index 9676da09b007..77606ad4240a 100644
--- a/games/lincity-ng/Makefile
+++ b/games/lincity-ng/Makefile
@@ -14,8 +14,7 @@ COMMENT= Improved rich city simulation game for X
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs
-USES= pkgconfig
-USE_BZIP2= yes
+USES= pkgconfig tar:bzip2
USE_SDL= sdl mixer image ttf gfx
USE_GL= yes
USE_GNOME= libxml2
diff --git a/games/netradiant/Makefile b/games/netradiant/Makefile
index 8163bdf3c812..f1feb060c5ae 100644
--- a/games/netradiant/Makefile
+++ b/games/netradiant/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libwebp.so:${PORTSDIR}/graphics/webp
-USES= gmake pkgconfig
-USE_BZIP2= yes
+USES= gmake pkgconfig tar:bzip2
USE_GL= gl
USE_GNOME= gtk20 libxml2
MAKE_ENV= BUILD=release DOWNLOAD_GAMEPACKS=no LIBS_DL="" \
diff --git a/games/nighthawk/Makefile b/games/nighthawk/Makefile
index 8304c0f0bb75..52ce6b84b537 100644
--- a/games/nighthawk/Makefile
+++ b/games/nighthawk/Makefile
@@ -12,8 +12,7 @@ COMMENT= X11 shoot-'em up which requires some lateral thinking
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
USE_GL= glut
MAKE_ARGS= CC="${CC}" CPP="${CXX}" CC_FLAGS="${CXXFLAGS}" \
LIB_FLAGS="${LDFLAGS}" GCC="${CC}" CFLAGS="${CFLAGS}"
diff --git a/games/qgo/Makefile b/games/qgo/Makefile
index 14c3132c0aa7..7249037d813c 100644
--- a/games/qgo/Makefile
+++ b/games/qgo/Makefile
@@ -12,8 +12,7 @@ COMMENT= Go board and SGF editor written with the Qt library
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_BZIP2= yes
-USES= desktop-file-utils qmake
+USES= desktop-file-utils qmake tar:bzip2
USE_QT4= gui network qtestlib moc_build rcc_build uic_build
PLIST_FILES= bin/qgo share/applications/qgo.desktop share/pixmaps/qgo.png
diff --git a/games/quetoo/Makefile b/games/quetoo/Makefile
index 8d2df1ff5d2e..42c88f2ad9d7 100644
--- a/games/quetoo/Makefile
+++ b/games/quetoo/Makefile
@@ -13,10 +13,9 @@ COMMENT= Fast, stable, compatible, and secure Quake II client
LICENSE= GPLv2
-USE_BZIP2= yes
USE_SDL= sdl
USE_GL= glut
-USES= dos2unix
+USES= dos2unix tar:bzip2
DOS2UNIX_FILES= src/vanctf/g_local.h
GNU_CONFIGURE= yes
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index eac78168b4e9..c22f9ef47404 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -17,8 +17,7 @@ BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
OPTIONS_DEFINE= DOCS
-USE_BZIP2= yes
-USES= gettext gmake perl5 pkgconfig
+USES= gettext gmake perl5 pkgconfig tar:bzip2
USE_GNOME= gtk20
USE_PYTHON= yes
GNU_CONFIGURE= yes
diff --git a/games/scid/Makefile b/games/scid/Makefile
index 1cd8c579c69a..7ef2f33be615 100644
--- a/games/scid/Makefile
+++ b/games/scid/Makefile
@@ -10,8 +10,7 @@ MAINTAINER= bsd@volki.at
COMMENT= Free chess database application
HAS_CONFIGURE= yes
-USES= gmake tk:84,85,86
-USE_BZIP2= yes
+USES= gmake tk:84,85,86 tar:bzip2
USE_PYTHON= yes
TCL_LIBRARY= -L${LOCALBASE}/lib -ltcl${TCL_SHLIB_VER}
diff --git a/games/sdlquake2/Makefile b/games/sdlquake2/Makefile
index 6a057b5254ee..b59cfe862039 100644
--- a/games/sdlquake2/Makefile
+++ b/games/sdlquake2/Makefile
@@ -12,8 +12,7 @@ COMMENT= Combination of R1Q2 and R1GL with SDL code from Quake2Forge
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
OPTIONS_DEFINE= CLIENT DEDICATED GAME
OPTIONS_DEFAULT= CLIENT DEDICATED
diff --git a/games/species/Makefile b/games/species/Makefile
index 123b8fd502b8..3d575fad19c7 100644
--- a/games/species/Makefile
+++ b/games/species/Makefile
@@ -13,8 +13,7 @@ COMMENT= Corewars evolver - generates warriors using genetic algorithms
LICENSE= GPLv1 # (or later)
-USE_BZIP2= yes
-USES= gmake dos2unix
+USES= gmake dos2unix tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= VISITOOL
diff --git a/games/stepmania-devel/Makefile b/games/stepmania-devel/Makefile
index 200a05b36855..703711141884 100644
--- a/games/stepmania-devel/Makefile
+++ b/games/stepmania-devel/Makefile
@@ -26,8 +26,7 @@ OPTIONS_DEFAULT=VORBIS
WRKSRC= ${WRKDIR}/${PORTNAME}-SM5-alpha3
-USE_BZIP2= yes
-USES= iconv pathfix perl5 pkgconfig shebangfix
+USES= iconv pathfix perl5 pkgconfig shebangfix tar:bzip2
USE_XORG= x11 xau xdmcp xext xrandr xrender xtst
USE_GL= gl glu
USE_GNOME= gtk20
diff --git a/games/tomenet/Makefile b/games/tomenet/Makefile
index 7e2d7f303243..6eca355d95c4 100644
--- a/games/tomenet/Makefile
+++ b/games/tomenet/Makefile
@@ -9,11 +9,10 @@ MASTER_SITES= http://tomenet.net/downloads/
MAINTAINER= culot@FreeBSD.org
COMMENT= Online multiplayer rogue-like role-playing game
-USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src
MAKEFILE= makefile
-USES= gmake ncurses
+USES= gmake ncurses tar:bzip2
CFLAGS+= -DDEFAULT_PATH="\\\"${DATADIR}/lib/\\\""
MAKE_JOBS_UNSAFE= yes
diff --git a/games/tycho/Makefile b/games/tycho/Makefile
index 2bcb4ad6d6aa..7b41357ec687 100644
--- a/games/tycho/Makefile
+++ b/games/tycho/Makefile
@@ -11,8 +11,7 @@ DISTNAME= redcoder
MAINTAINER= ports@FreeBSD.org
COMMENT= Program to gather data (statistics) on Core War warriors
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/tycho \
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 9e3a659c933f..9c6acc71b06f 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -23,10 +23,9 @@ LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
BUILD_DEPENDS= ${LOCALBASE}/include/mxml.h:${PORTSDIR}/textproc/mxml
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/base/default.cfg:${PORTSDIR}/games/ufoai-data
-USE_BZIP2= yes
USE_GL= yes
USE_SDL= sdl image mixer ttf
-USES= gettext gmake openal:soft pkgconfig
+USES= gettext gmake openal:soft pkgconfig tar:bzip2
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-release
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
diff --git a/games/vdrift/Makefile b/games/vdrift/Makefile
index 7b5ed7b08649..26b8884ef503 100644
--- a/games/vdrift/Makefile
+++ b/games/vdrift/Makefile
@@ -21,7 +21,6 @@ LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
libboost_thread.so:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/settings/VDrift.config:${PORTSDIR}/games/vdrift-data
-USE_BZIP2= yes
USE_GL= glew
USE_SDL= sdl image net gfx
@@ -47,7 +46,7 @@ SCONS_ARGS+= release=1
.endif
.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
+USES+= gettext tar:bzip2
PLIST_SUB+= NLS=""
FLAG_NLS= true
.else
diff --git a/games/wizznic/Makefile b/games/wizznic/Makefile
index cd4b577cab3b..2d2f44c97003 100644
--- a/games/wizznic/Makefile
+++ b/games/wizznic/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
USE_SDL= image mixer sdl
MAKE_ENV= DATADIR=${DATADIR}/ BINDIR=${PREFIX}/bin
ALL_TARGET= sdl
diff --git a/games/xpilot/Makefile b/games/xpilot/Makefile
index 4dc95d5182f2..5e6768b3abe9 100644
--- a/games/xpilot/Makefile
+++ b/games/xpilot/Makefile
@@ -9,8 +9,7 @@ MASTER_SITES= SF/${PORTNAME}game/${PORTNAME}-4/${PORTNAME}-${PORTVERSION}
MAINTAINER= lme@FreeBSD.org
COMMENT= Xpilot(client) and xpilots(server)
-USE_BZIP2= yes
USE_XORG= x11 xext
-USES= imake
+USES= imake tar:bzip2
.include <bsd.port.mk>