aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/freedink-dfarc/Makefile28
-rw-r--r--games/freedink-dfarc/distinfo3
-rw-r--r--games/freedink-dfarc/files/patch-po_Makefile.in.in19
-rw-r--r--games/freedink-dfarc/pkg-descr2
-rw-r--r--games/freedink-dfarc/pkg-plist17
6 files changed, 70 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 4939244ee397..c66dc2fb5589 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -249,6 +249,7 @@
SUBDIR += freeciv-sounds
SUBDIR += freecol
SUBDIR += freedink-data
+ SUBDIR += freedink-dfarc
SUBDIR += freedink-engine
SUBDIR += freedoko
SUBDIR += freedroid
diff --git a/games/freedink-dfarc/Makefile b/games/freedink-dfarc/Makefile
new file mode 100644
index 000000000000..496e80188314
--- /dev/null
+++ b/games/freedink-dfarc/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: syncterm
+# Date created: 3 October 2006
+# Whom: shurd
+#
+# $FreeBSD$
+#
+
+PORTNAME= freedink-dfarc
+PORTVERSION= 3.2.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= freedink
+DISTNAME= dfarc-${PORTVERSION}
+
+MAINTAINER= shurd@sasktel.net
+COMMENT= Frontend and .dmod installer for GNU FreeDink
+
+LIB_DEPENDS= iconv:${PORTSDIR}/textproc/intltool
+
+USE_GMAKE= yes
+USE_WX= 2.6+
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG} --disable-upx --disable-static
+
+MAN1= dfarc.1
+
+.include <bsd.port.mk>
diff --git a/games/freedink-dfarc/distinfo b/games/freedink-dfarc/distinfo
new file mode 100644
index 000000000000..192d1998b702
--- /dev/null
+++ b/games/freedink-dfarc/distinfo
@@ -0,0 +1,3 @@
+MD5 (dfarc-3.2.1.tar.gz) = 77e1a31c04d0e6bcf1171f2229834e7b
+SHA256 (dfarc-3.2.1.tar.gz) = 0e31f65ea6e6183ef1f7158d44fbf442ddcae21eec0ec0274d4911683df6e175
+SIZE (dfarc-3.2.1.tar.gz) = 202479
diff --git a/games/freedink-dfarc/files/patch-po_Makefile.in.in b/games/freedink-dfarc/files/patch-po_Makefile.in.in
new file mode 100644
index 000000000000..ee14768bcd00
--- /dev/null
+++ b/games/freedink-dfarc/files/patch-po_Makefile.in.in
@@ -0,0 +1,19 @@
+*** po/Makefile.in.in.orig Tue Sep 30 19:11:33 2008
+--- po/Makefile.in.in Tue Sep 30 19:11:48 2008
+***************
+*** 34,40 ****
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+! itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+--- 34,40 ----
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+! itlocaledir = $(datarootdir)/locale
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
diff --git a/games/freedink-dfarc/pkg-descr b/games/freedink-dfarc/pkg-descr
new file mode 100644
index 000000000000..4510023c7447
--- /dev/null
+++ b/games/freedink-dfarc/pkg-descr
@@ -0,0 +1,2 @@
+DFArc2 makes it easy to play and manage the Dink Smallwood game and
+it's numerous Dink Modules (or D-Mods).
diff --git a/games/freedink-dfarc/pkg-plist b/games/freedink-dfarc/pkg-plist
new file mode 100644
index 000000000000..3c173fbf64ab
--- /dev/null
+++ b/games/freedink-dfarc/pkg-plist
@@ -0,0 +1,17 @@
+bin/dfarc
+share/icons/hicolor/32x32/mimetypes/application-x-dmod.png
+share/applications/freedink-dfarc.desktop
+share/mime/packages/freedink-mime.xml
+share/pixmaps/dfarc.png
+share/locale/fr/LC_MESSAGES/dfarc.mo
+share/locale/pl/LC_MESSAGES/dfarc.mo
+share/locale/fi/LC_MESSAGES/dfarc.mo
+@dirrmtry icons/hicolor/32x32/mimetypes
+@dirrmtry share/applications
+@dirrmtry share/mime/packages
+@dirrmtry share/mime
+@dirrmtry share/pixmaps
+@dirrmtry share/icons/hicolor/32x32/mimetypes
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons