aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/gnubg/Makefile3
-rw-r--r--games/gnubg/files/patch-export.c13
2 files changed, 16 insertions, 0 deletions
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index a6130ece8dab..4204fb76ab76 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -72,6 +72,9 @@ LDFLAGS= -L${LOCALBASE}/lib
post-extract:
${GUNZIP_CMD} --stdout ${DISTDIR}/${DIST_SUBDIR}/gnubg_ts0.bd.gz > ${WRKSRC}/gnubg_ts0.bd
+post-patch:
+ ${REINPLACE_CMD} -e 's|libpng12|libpng14|g' ${WRKSRC}/configure.in
+
pre-configure:
cd ${WRKSRC} && ./autogen.sh
diff --git a/games/gnubg/files/patch-export.c b/games/gnubg/files/patch-export.c
new file mode 100644
index 000000000000..47459b17a469
--- /dev/null
+++ b/games/gnubg/files/patch-export.c
@@ -0,0 +1,13 @@
+--- export.c.orig 2007-05-24 07:20:04.000000000 +0200
++++ export.c 2010-03-30 14:44:05.000000000 +0200
+@@ -116,8 +116,8 @@
+ atext[1].compression = PNG_TEXT_COMPRESSION_NONE;
+
+ #ifdef PNG_iTXt_SUPPORTED
+- text_ptr[0].lang = NULL;
+- text_ptr[1].lang = NULL;
++// text_ptr[0].lang = NULL;
++// text_ptr[1].lang = NULL;
+ #endif
+ png_set_text (ppng, pinfo, atext, 2);
+