aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/brutalchess/files/patch-src_fontloader.h17
-rw-r--r--games/openmortal/files/patch-src-sge__tt__text.cpp17
-rw-r--r--games/scorched3d/Makefile5
-rw-r--r--games/scorched3d/files/patch-src_client_GLEXT_GLFont2dFreeType.h17
-rw-r--r--games/scorched3d/files/patch-src_launcher_wxdialogs_TrueTypeFont.h17
5 files changed, 70 insertions, 3 deletions
diff --git a/games/brutalchess/files/patch-src_fontloader.h b/games/brutalchess/files/patch-src_fontloader.h
new file mode 100644
index 000000000000..e1434464ce8d
--- /dev/null
+++ b/games/brutalchess/files/patch-src_fontloader.h
@@ -0,0 +1,17 @@
+--- src/fontloader.h.orig 2013-12-13 10:49:49.000000000 +0100
++++ src/fontloader.h 2013-12-13 10:50:39.000000000 +0100
+@@ -12,11 +12,9 @@
+ //FreeType Headers
+ #include <ft2build.h>
+ #include FT_FREETYPE_H
+-
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
++#include FT_TRIGONOMETRY_H
+
+ // Other Headers we'll need.
+ #include <vector>
diff --git a/games/openmortal/files/patch-src-sge__tt__text.cpp b/games/openmortal/files/patch-src-sge__tt__text.cpp
index 0df428b3db45..4cef2d593c2c 100644
--- a/games/openmortal/files/patch-src-sge__tt__text.cpp
+++ b/games/openmortal/files/patch-src-sge__tt__text.cpp
@@ -1,5 +1,5 @@
---- src/sge_tt_text.cpp.orig Tue Sep 12 18:29:07 2006
-+++ src/sge_tt_text.cpp Tue Sep 12 18:29:12 2006
+--- src/sge_tt_text.cpp.orig 2004-03-03 21:17:48.000000000 +0100
++++ src/sge_tt_text.cpp 2013-12-13 11:24:58.000000000 +0100
@@ -26,7 +26,6 @@
#include "SDL.h"
@@ -8,3 +8,16 @@
#include <memory.h>
#include <string.h>
#include <stdarg.h>
+@@ -37,9 +36,9 @@
+
+ #ifndef _SGE_NOTTF
+ #include <ft2build.h>
+-#include <freetype/freetype.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/ttnameid.h>
++#include FT_FREETYPE_H
++#include FT_OUTLINE_H
++#include FT_TRUETYPE_IDS_H
+
+ /* The structure used to hold glyph information (cached) */
+ struct glyph {
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index 7c52265fb8e7..1e8f83e79a5b 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -30,12 +30,15 @@ USE_OPENAL= al alut
USE_SDL= mixer net sdl
USE_WX= 2.4+
WX_CONF_ARGS= absolute
-USES= iconv perl5 gmake pkgconfig
+USES= dos2unix iconv perl5 gmake pkgconfig
USE_AUTOTOOLS= aclocal automake autoconf
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing --copy --force --foreign
CONFIGURE_ARGS= --datadir=${DATADIR}
+DOS2UNIX_FILES= src/client/GLEXT/GLFont2dFreeType.h \
+ src/launcher/wxdialogs/TrueTypeFont.h
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/scorched3d/files/patch-src_client_GLEXT_GLFont2dFreeType.h b/games/scorched3d/files/patch-src_client_GLEXT_GLFont2dFreeType.h
new file mode 100644
index 000000000000..5bcad3c1b8ff
--- /dev/null
+++ b/games/scorched3d/files/patch-src_client_GLEXT_GLFont2dFreeType.h
@@ -0,0 +1,17 @@
+--- src/client/GLEXT/GLFont2dFreeType.h.orig 2013-12-17 09:58:11.000000000 +0100
++++ src/client/GLEXT/GLFont2dFreeType.h 2013-12-17 09:59:18.000000000 +0100
+@@ -23,10 +23,10 @@
+
+ #include <GLEXT/GLFont2dStorage.h>
+ #include <ft2build.h>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include FT_FREETYPE_H
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
++#include FT_TRIGONOMETRY_H
+ #include <string>
+
+ class GLFont2dFreeType
diff --git a/games/scorched3d/files/patch-src_launcher_wxdialogs_TrueTypeFont.h b/games/scorched3d/files/patch-src_launcher_wxdialogs_TrueTypeFont.h
new file mode 100644
index 000000000000..d3f212392a55
--- /dev/null
+++ b/games/scorched3d/files/patch-src_launcher_wxdialogs_TrueTypeFont.h
@@ -0,0 +1,17 @@
+--- src/launcher/wxdialogs/TrueTypeFont.h.orig 2013-12-17 10:01:02.000000000 +0100
++++ src/launcher/wxdialogs/TrueTypeFont.h 2013-12-17 10:01:16.000000000 +0100
+@@ -25,10 +25,10 @@
+ #include <wx/image.h>
+ #include <ft2build.h>
+ #include <string>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttrigon.h>
++#include FT_FREETYPE_H
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
++#include FT_TRIGONOMETRY_H
+
+ class TrueTypeFont
+ {