aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/tome4/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/tome4/Makefile b/games/tome4/Makefile
index bb038ebac130..e152ed24b7ec 100644
--- a/games/tome4/Makefile
+++ b/games/tome4/Makefile
@@ -31,6 +31,9 @@ USE_CSTD= gnu89
SUB_FILES= tome4
MAKE_JOBS_UNSAFE=yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/src/lua/Makefile \
+ ${WRKSRC}/src/luabitop/Makefile ${WRKSRC}/build/te4core.lua
pre-build:
@${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/premake4.lua
(cd ${WRKSRC} && premake4 gmake)