aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/starlanes/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/games/starlanes/Makefile b/games/starlanes/Makefile
index ead560557eac..86cfc9b47743 100644
--- a/games/starlanes/Makefile
+++ b/games/starlanes/Makefile
@@ -9,10 +9,8 @@ MASTER_SITES= SUNSITE/games/strategy
MAINTAINER= ports@FreeBSD.org
COMMENT= Classic space-age stock trading game
-MAN6= starlanes.6
-PLIST_FILES= bin/starlanes
+PLIST_FILES= bin/starlanes man/man6/starlanes.6.gz
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
's| restrict| m_restrict| ; \
@@ -23,7 +21,7 @@ do-build:
&& ${CC} ${CFLAGS} -o starlanes starlanes.c -lcurses)
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} starlanes ${PREFIX}/bin)
- (cd ${WRKSRC} && ${INSTALL_MAN} starlanes.6 ${MAN6PREFIX}/man/man6)
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} starlanes ${STAGEDIR}${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_MAN} starlanes.6 ${STAGEDIR}${MAN6PREFIX}/man/man6)
.include <bsd.port.mk>