aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/ggz-txt-client/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/games/ggz-txt-client/Makefile b/games/ggz-txt-client/Makefile
index a7c000a800b9..d1209d537f26 100644
--- a/games/ggz-txt-client/Makefile
+++ b/games/ggz-txt-client/Makefile
@@ -9,6 +9,7 @@ CATEGORIES= games
MAINTAINER= ports@FreeBSD.org
COMMENT= The GGZ Gaming Zone - Console (Text) Frontend
+USES= readline
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug
USE_GGZ= client
@@ -16,7 +17,7 @@ USE_GGZ= client
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -pthread
+LDFLAGS+= -L${LOCALBASE}/lib -pthread -lexpat
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
@@ -24,6 +25,10 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ARGS= --disable-nls
+post-patch:
+ @${REINPLACE_CMD} -e 's|_LDADD =|_LDADD = $$(LIB_GGZCORE)|' \
+ ${WRKSRC}/tttxt/Makefile.in
+
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/ggz
@${INSTALL_DATA} ${WRKSRC}/tttxt/module.dsc ${STAGEDIR}/${PREFIX}/share/ggz/tttxt.dsc