aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/xmris/Makefile2
-rw-r--r--games/xmris/files/patch-timer.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/games/xmris/Makefile b/games/xmris/Makefile
index 5bb21c6617d8..209c89e88e84 100644
--- a/games/xmris/Makefile
+++ b/games/xmris/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmris
PORTVERSION= 4.04
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= XCONTRIB/games
DISTNAME= ${PORTNAME}.${PORTVERSION}
diff --git a/games/xmris/files/patch-timer.c b/games/xmris/files/patch-timer.c
index 2bb57c41ed41..f2482ed1d734 100644
--- a/games/xmris/files/patch-timer.c
+++ b/games/xmris/files/patch-timer.c
@@ -9,3 +9,14 @@
#else
# ifdef __hpux /* hpux is a weird mixture of BSD & SYSV */
/* don't know if this is right */
+@@ -572,7 +572,10 @@ extern VOIDFUNC timer_wait FUNCARGVOID
+ else
+ {
+ while(!tickafter(now, timer.timeout))
++ {
++ usleep(tickdelta(timer.timeout, now) * TICKTIME);
+ gettick(&now);
++ }
+ timer.timeout = tickadd(timer.timeout, timer.delay);
+ point = -1;
+ }