aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/vavoom/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index 2b23394f61c9..0e8fb8f207dc 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -33,8 +33,6 @@ OPTIONS= ALLEGRO "Use Allegro for hardware API" off \
SUB_FILES= pkg-message
-BROKEN= fails to build with new cmake.
-
.include <bsd.port.pre.mk>
# The `-fno-strict-aliasing' flag (default on FreeBSD 6.0+) produces
@@ -137,6 +135,19 @@ post-patch:
@${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' \
${WRKSRC}/utils/acc/strlist.c
+.if defined(WITH_LAUNCHER)
+ @${REINPLACE_CMD} -e '/add_definitions($${wxWidgets_DEFINITIONS})/d; \
+ s/include_directories($${wxWidgets_INCLUDE_DIRS})/include($${wxWidgets_USE_FILE})/' \
+ ${WRKSRC}/utils/vlaunch/CMakeLists.txt
+.endif
+
+post-configure:
+.if defined(WITH_LAUNCHER)
+ @${REINPLACE_CMD} -e 's/-pthread;-D_THREAD_SAFE //; \
+ s/-isystem /-I/g' \
+ ${WRKSRC}/utils/vlaunch/CMakeFiles/vlaunch.dir/flags.make
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}