aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/54321/Makefile4
-rw-r--r--games/54321/files/variables.GNU6
2 files changed, 7 insertions, 3 deletions
diff --git a/games/54321/Makefile b/games/54321/Makefile
index c65aeba9e4e4..5729355181fe 100644
--- a/games/54321/Makefile
+++ b/games/54321/Makefile
@@ -22,11 +22,15 @@ USE_SDL= image sdl
USE_GMAKE= yes
MAKEFILE= GNUmakefile
ALL_TARGET= all size
+USE_REINPLACE= yes
post-extract:
@${MKDIR} ${WRKSRC}/archs/FreeBSD
@${CP} ${FILESDIR}/variables.GNU ${WRKSRC}/archs/FreeBSD
+post-patch:
+ ${REINPLACE_CMD} -e "s,ARCH,OPSYS," ${WRKSRC}/GNUmakefile
+
post-build:
@${SED} -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/54321.sh > ${WRKSRC}/54321
diff --git a/games/54321/files/variables.GNU b/games/54321/files/variables.GNU
index e5867629c037..b833cd43716b 100644
--- a/games/54321/files/variables.GNU
+++ b/games/54321/files/variables.GNU
@@ -14,10 +14,10 @@ LDFLAGS += \
-L${SDL}/lib -Wl,-rpath -Wl,${SDL}/lib \
-lSDL_image -lSDL-1.1 -lSDLmain-1.1 -pthread -lpng
-prog: Release/54321-$(ARCH)
+prog: Release/54321-$(OPSYS)
-Release/54321-$(ARCH):
+Release/54321-$(OPSYS):
-@$(MKDIR_CMD)
echo '#!/bin/sh' > $@
- echo "cd ./bin/$(ARCH) && exec ./54321 \$$*" >> $@
+ echo "cd ./bin/$(OPSYS) && exec ./54321 \$$*" >> $@
chmod 755 $@