aboutsummaryrefslogtreecommitdiffstats
path: root/german/dtaus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'german/dtaus/Makefile')
-rw-r--r--german/dtaus/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/german/dtaus/Makefile b/german/dtaus/Makefile
new file mode 100644
index 000000000000..6fb375c994b6
--- /dev/null
+++ b/german/dtaus/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: dtaus
+# Date created: 12 Jan 2009
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= dtaus
+PORTVERSION= 0.7
+CATEGORIES= german finance
+MASTER_SITES= http://www.infodrom.org/projects/dtaus/download/
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Belegloser DatenTraegerAUStausch
+
+ALL_TARGET= dtaus
+PLIST_FILES= bin/dtaus
+
+PORTDOCS= ChangeLog README TODO dtaus.txt
+PORTEXAMPLES= dtaus.cls sample.ctl
+MAN1= dtaus.1
+MAN5= dtaus.5
+
+do-configure:
+ ${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' \
+ ${WRKSRC}/bigint.c ${WRKSRC}/dtaus.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dtaus ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/dtaus.1 ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/dtaus.5 ${PREFIX}/man/man5/
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} \
+ ${DOCSDIR}/
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+.for doc in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} \
+ ${EXAMPLESDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>