aboutsummaryrefslogtreecommitdiffstats
path: root/german/unix-connect/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'german/unix-connect/Makefile')
-rw-r--r--german/unix-connect/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/german/unix-connect/Makefile b/german/unix-connect/Makefile
index 8c8c501da5c1..ad82e50501cb 100644
--- a/german/unix-connect/Makefile
+++ b/german/unix-connect/Makefile
@@ -20,8 +20,13 @@ NEED_ROOT= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= yes
+.if !defined(INSTALL_AS_USER)
CONFIGURE_ARGS+=--with-user=news
CONFIGURE_ARGS+=--with-group=dialer
+.else
+CONFIGURE_ARGS+=--with-user=`id -u -n`
+CONFIGURE_ARGS+=--with-group=`id -g -n`
+.endif
CONFIGURE_ARGS+=--with-execdir=${PREFIX}/libexec/uconnect
CONFIGURE_ARGS+=--with-confdir=${PREFIX}/etc/uconnect
CONFIGURE_ARGS+=--with-spooldir=/var/spool/uconnect