aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ImageMagick/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ImageMagick/Makefile')
-rw-r--r--graphics/ImageMagick/Makefile41
1 files changed, 25 insertions, 16 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 2d9c61a93d95..938a3a9edcb6 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -6,65 +6,74 @@
#
PORTNAME= ImageMagick
-PORTVERSION= 5.2.7
-PORTREVISION= 2
+PORTVERSION= 5.2.9
CATEGORIES= graphics perl5
-MASTER_SITES= ftp://ftp.simplesystems.org/pub/ImageMagick/ \
+MASTER_SITES= ftp://ftp.yggdrasil.com/mirrors/site/ftp.simplesystems.org/pub/ImageMagick/ \
ftp://ftp.cdrom.com/pub/ImageMagick/ \
ftp://ftp.u-aizu.ac.jp/pub/graphics/image/ImageMagick/ \
ftp://ftp.fifi.org/pub/ImageMagick/ \
ftp://gd.tuwien.ac.at/pub/graphics/ImageMagick/ \
- ftp://ftp.ms.mff.cuni.cz/MIRRORS/ftp.wizards.dupont.com/pub/ImageMagick/ \
- ftp://ftp.oce.nl/pub/Internet/audio+video/ImageMagick/
+ ftp://ftp.simplesystems.org/pub/ImageMagick/ \
+ ${MASTER_SITE_RINGSERVER}
+MASTER_SITE_SUBDIR= graphics/ImageMagick
-MAINTAINER= jseger@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= bz2.1:${PORTSDIR}/archivers/bzip2 \
+ ltdl.1:${PORTSDIR}/devel/libtool \
df.1:${PORTSDIR}/graphics/hdf \
jbig.1:${PORTSDIR}/graphics/jbigkit \
jpeg.9:${PORTSDIR}/graphics/jpeg \
+ lcms.1:${PORTSDIR}/graphics/lcms \
wmf.1:${PORTSDIR}/graphics/libwmf \
png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- freetype.6:${PORTSDIR}/print/freetype2
+ freetype.6:${PORTSDIR}/print/freetype2 \
+ xml2.5:${PORTSDIR}/textproc/libxml2
BUILD_DEPENDS= gs:${PORTSDIR}/print/ghostscript55 \
mpeg2decode:${PORTSDIR}/graphics/mpeg2codec \
picttoppm:${PORTSDIR}/graphics/netpbm \
fig2dev:${PORTSDIR}/print/transfig
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript55 \
- mpeg2decode:${PORTSDIR}/graphics/mpeg2codec \
- picttoppm:${PORTSDIR}/graphics/netpbm \
- fig2dev:${PORTSDIR}/print/transfig
+RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PERL5= yes
USE_XLIB= yes
USE_LIBTOOL= yes
+LIBTOOLFLAGS= # empty
USE_AUTOCONF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --enable-shared --without-modules \
- --without-magick-plus-plus \
- --with-perl=${PERL5} --without-xml
+CONFIGURE_ARGS= --enable-shared --with-modules \
+ --with-perl=${PERL5}
INSTALLS_SHLIB= yes
.if defined(PERL_THREADED) && ${PERL_THREADED} == "true"
CONFIGURE_ARGS+= --with-threads
+.else
+CONFIGURE_ARGS+= --without-threads
.endif
.if defined(WITH_16BIT_PIXEL)
CONFIGURE_ARGS+= --enable-16bit-pixel
+.else
+CONFIGURE_ARGS+= --disable-16bit-pixel
.endif
.if defined(HAVE_UNISYS_LICENSE)
CONFIGURE_ARGS+= --enable-lzw
.endif
-MAN1= ImageMagick.1 Magick-config.1 animate.1 combine.1 convert.1 \
- display.1 identify.1 import.1 mogrify.1 montage.1
+MAN1= ImageMagick.1 Magick++-config.1 Magick-config.1 \
+ animate.1 combine.1 convert.1 display.1 identify.1 \
+ import.1 mogrify.1 montage.1
MAN3= Image::Magick.3
MAN4= miff.4
MAN5= quantize.5
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+pre-patch:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$$\(top_builddir\)/ltdl/libltdlc.la|\$$\(LIBLTDL\)|g'
+
.include <bsd.port.mk>