aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ImageMagick/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ImageMagick/Makefile')
-rw-r--r--graphics/ImageMagick/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index cb0bb2ad75b5..7802e4185c61 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -148,6 +148,7 @@ CONFIGURE_ARGS+= --without-lcms
.if defined(WITH_IMAGEMAGICK_TTF)
BUILD_DEPENDS+= freetype-config:${PORTSDIR}/print/freetype2 # XXX
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+NEED_GS= yes
.else
CONFIGURE_ARGS+= --without-ttf
.endif
@@ -178,13 +179,7 @@ CONFIGURE_ARGS+= --without-dps
# PDF (Adobe Portable Document Format) support
.if defined(WITH_IMAGEMAGICK_PDF)
CONFIGURE_ARGS+= --with-gslib
-.if defined(WITHOUT_X11)
-BUILD_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu-nox11
-RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu-nox11
-.else
-BUILD_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
-RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
-.endif
+NEED_GS= yes
.else
CONFIGURE_ARGS+= --without-gslib
.endif
@@ -206,6 +201,16 @@ CONFIGURE_ARGS+= --without-mpeg2
.endif
.endif
+.if defined(NEED_GS)
+.if defined(WITHOUT_X11)
+BUILD_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu-nox11
+RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu-nox11
+.else
+BUILD_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
+RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
+.endif
+.endif
+
.if defined(NOPORTDOCS)
INSTALL_TARGET= install
.else