aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ImageMagick/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ImageMagick/Makefile')
-rw-r--r--graphics/ImageMagick/Makefile33
1 files changed, 25 insertions, 8 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 938a3a9edcb6..3c2af59ed56f 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -19,25 +19,31 @@ MASTER_SITE_SUBDIR= graphics/ImageMagick
MAINTAINER= ports@FreeBSD.org
+RUN_DEPENDS= ${BUILD_DEPENDS}
LIB_DEPENDS= bz2.1:${PORTSDIR}/archivers/bzip2 \
ltdl.1:${PORTSDIR}/devel/libtool \
df.1:${PORTSDIR}/graphics/hdf \
jbig.1:${PORTSDIR}/graphics/jbigkit \
jpeg.9:${PORTSDIR}/graphics/jpeg \
lcms.1:${PORTSDIR}/graphics/lcms \
- wmf.1:${PORTSDIR}/graphics/libwmf \
png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
freetype.6:${PORTSDIR}/print/freetype2 \
xml2.5:${PORTSDIR}/textproc/libxml2
-BUILD_DEPENDS= gs:${PORTSDIR}/print/ghostscript55 \
- mpeg2decode:${PORTSDIR}/graphics/mpeg2codec \
- picttoppm:${PORTSDIR}/graphics/netpbm \
+BUILD_DEPENDS= picttoppm:${PORTSDIR}/graphics/netpbm
+
+.ifndef NO_X
+BUILD_DEPENDS+= mpeg2decode:${PORTSDIR}/graphics/mpeg2codec \
+ gs:${PORTSDIR}/print/ghostscript6 \
fig2dev:${PORTSDIR}/print/transfig
-RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS+= wmf.1:${PORTSDIR}/graphics/libwmf
+USE_XLIB= yes
+.else
+BUILD_DEPENDS+= gs:${PORTSDIR}/print/ghostscript6-nox11
+PKGNAMESUFFIX= -nox11
+.endif
USE_PERL5= yes
-USE_XLIB= yes
USE_LIBTOOL= yes
LIBTOOLFLAGS= # empty
USE_AUTOCONF= yes
@@ -45,6 +51,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-shared --with-modules \
--with-perl=${PERL5}
+
+.ifdef NO_X
+CONFIGURE_ARGS+=--without-x
+PLIST_SUB+= X11='@comment '
+.else
+PLIST_SUB+= X11=''
+.endif
+
INSTALLS_SHLIB= yes
.if defined(PERL_THREADED) && ${PERL_THREADED} == "true"
@@ -64,12 +78,15 @@ CONFIGURE_ARGS+= --enable-lzw
.endif
MAN1= ImageMagick.1 Magick++-config.1 Magick-config.1 \
- animate.1 combine.1 convert.1 display.1 identify.1 \
- import.1 mogrify.1 montage.1
+ combine.1 convert.1 identify.1 mogrify.1 montage.1
MAN3= Image::Magick.3
MAN4= miff.4
MAN5= quantize.5
+.ifndef NO_X
+MAN1+= animate.1 display.1 import.1
+.endif
+
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
pre-patch: