aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/R-cran-ggplot2
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/R-cran-ggplot2')
-rw-r--r--graphics/R-cran-ggplot2/Makefile29
-rw-r--r--graphics/R-cran-ggplot2/distinfo2
-rw-r--r--graphics/R-cran-ggplot2/pkg-descr8
3 files changed, 39 insertions, 0 deletions
diff --git a/graphics/R-cran-ggplot2/Makefile b/graphics/R-cran-ggplot2/Makefile
new file mode 100644
index 000000000000..39afe2de9c36
--- /dev/null
+++ b/graphics/R-cran-ggplot2/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: R-cran-ggplot2
+# Date created: 2011-09-10
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ggplot2
+PORTVERSION= 0.8.9
+CATEGORIES= graphics
+PKGNAMEPREFIX= R-cran-
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= An implementation of the Grammar of Graphics
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= R-cran-reshape>=0.8.0:${PORTSDIR}/devel/R-cran-reshape \
+ R-cran-proto>0:${PORTSDIR}/devel/R-cran-proto \
+ R-cran-plyr>0:${PORTSDIR}/devel/R-cran-plyr \
+ R-cran-RColorBrewer>0:${PORTSDIR}/graphics/R-cran-RColorBrewer \
+ R-cran-digest>0:${PORTSDIR}/security/R-cran-digest \
+ R-cran-colorspace>0:${PORTSDIR}/graphics/R-cran-colorspace
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/R-cran-ggplot2/distinfo b/graphics/R-cran-ggplot2/distinfo
new file mode 100644
index 000000000000..027519b041f3
--- /dev/null
+++ b/graphics/R-cran-ggplot2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ggplot2_0.8.9.tar.gz) = d43b4a7aea48a32245279b8d71cedf2df3b826a7789a08e00742d0cc5820407e
+SIZE (ggplot2_0.8.9.tar.gz) = 2074749
diff --git a/graphics/R-cran-ggplot2/pkg-descr b/graphics/R-cran-ggplot2/pkg-descr
new file mode 100644
index 000000000000..20ca67785ba1
--- /dev/null
+++ b/graphics/R-cran-ggplot2/pkg-descr
@@ -0,0 +1,8 @@
+ggplot2 is a plotting system for R, based on the grammar of graphics,
+which tries to take the good parts of base and lattice graphics and
+none of the bad parts. It takes care of many of the fiddly details
+that make plotting a hassle (like drawing legends) as well as
+providing a powerful model of graphics that makes it easy to produce
+complex multi-layered graphics.
+
+WWW: http://had.co.nz/ggplot2/