aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/animabob/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/animabob/Makefile')
-rw-r--r--graphics/animabob/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/animabob/Makefile b/graphics/animabob/Makefile
new file mode 100644
index 000000000000..da3b44f23c76
--- /dev/null
+++ b/graphics/animabob/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: animabob
+# Date created: 21 July 2002
+# Whom: Igor Pokrovsky <tiamat@telegraph.spb.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= animabob
+PORTVERSION= 1.3.0b
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.borg.umn.edu/pub/lcse/grant/AnimaBob/
+
+MAINTAINER= tiamat@telegraph.spb.ru
+COMMENT= Interactive 3D volume renderer
+
+USE_IMAKE= yes
+USE_MESA= yes
+USE_MOTIF= yes
+USE_REINPLACE= yes
+ALL_TARGET= build
+
+MAN1= animabob.1 icol.1
+MANCOMPRESSED= yes
+
+post-build:
+# make the doc installation PREFIX safe
+ @${REINPLACE_CMD} -E \
+ -e 's|(DOCDIR[[:space:]]*=).*$$|\1${PREFIX}/lib/X11/doc|' \
+ ${WRKSRC}/doc/Makefile
+
+.include <bsd.port.mk>