aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/dcraw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dcraw/Makefile')
-rw-r--r--graphics/dcraw/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/dcraw/Makefile b/graphics/dcraw/Makefile
index c160c6282907..f136f9658f2c 100644
--- a/graphics/dcraw/Makefile
+++ b/graphics/dcraw/Makefile
@@ -12,15 +12,16 @@ COMMENT= Decoder for RAW files from digital cameras
LIB_DEPENDS= libjasper.so:graphics/jasper \
liblcms2.so:graphics/lcms2
-CFLAGS+= -I${LOCALBASE}/include/jasper
-LDFLAGS+= -ljasper -ljpeg -llcms2 -lm
+CPPFLAGS+= -I${LOCALBASE}/include/jasper
+LIBS+= -ljasper -ljpeg -llcms2 -lm
USES= jpeg localbase tar:xz
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
do-build:
- @cd ${WRKSRC}/ && ${CC} -o ${PORTNAME} ${CFLAGS} ${PORTNAME}.c ${LDFLAGS}
+ @cd ${WRKSRC}/ && ${CC} -o ${PORTNAME} ${CPPFLAGS} ${CFLAGS} \
+ ${PORTNAME}.c ${LDFLAGS} ${LIBS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/