aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/dri/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dri/Makefile')
-rw-r--r--graphics/dri/Makefile37
1 files changed, 21 insertions, 16 deletions
diff --git a/graphics/dri/Makefile b/graphics/dri/Makefile
index de1200fee370..9407bd12e9dc 100644
--- a/graphics/dri/Makefile
+++ b/graphics/dri/Makefile
@@ -1,4 +1,4 @@
-# Created by: anholt@FreeBSD.org
+# Created by: Eric Anholt <anholt@FreeBSD.org>
# $FreeBSD$
PORTNAME= dri
@@ -10,27 +10,30 @@ CATEGORIES= graphics
COMMENT= OpenGL hardware acceleration drivers for the DRI
LIB_DEPENDS= drm:${PORTSDIR}/graphics/libdrm \
- expat.6:${PORTSDIR}/textproc/expat2
+ expat:${PORTSDIR}/textproc/expat2
USES= pkgconfig
USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto
-ALL_DRI_DRIVERS=I810 I915 I965 MACH64 MGA R128 R200 R300 R600 RADEON \
- SAVAGE SIS SWRAST TDFX UNICHROME
+ALL_DRI_DRIVERS=I915 I965 R200 RADEON SWRAST
+
+.if ! defined(WITH_NEW_XORG)
+ALL_DRI_DRIVERS+=I810 MACH64 MGA R128 R300 R600 SAVAGE SIS TDFX UNICHROME
+.endif
.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
-.if ${ARCH} == "ia64"
-BROKEN= does not install on ia64
-.endif
+OPTIONS_DEFINE_i386= ${ALL_DRI_DRIVERS}
+OPTIONS_DEFINE_amd64= ${OPTIONS_DEFINE_i386}
-.if ${ARCH} == "amd64" || ${ARCH} == "i386"
-OPTIONS_DEFINE= ${ALL_DRI_DRIVERS}
-.elif ${ARCH} == "powerpc"
-OPTIONS_DEFINE= MACH64 RADEON SWRAST TDFX
-.elif ${ARCH} == "sparc64"
-OPTIONS_DEFINE= MACH64 RADEON SWRAST
+.if defined(WITH_NEW_XORG)
+OPTIONS_DEFINE_powerpc= RADEON SWRAST
+OPTIONS_DEFINE_sparc64= RADEON SWRAST
+.else
+OPTIONS_DEFINE_powerpc= MACH64 RADEON SWRAST TDFX
+OPTIONS_DEFINE_sparc64= MACH64 RADEON SWRAST
.endif
+
OPTIONS_DEFAULT=${OPTIONS_DEFINE}
I810_DESC= Include DRI support for Intel i810
@@ -42,7 +45,7 @@ R128_DESC= Include DRI support for AMD/ATI R128
R200_DESC= Include DRI support for AMD/ATI R200
R300_DESC= Include DRI support for AMD/ATI R300
R600_DESC= Include DRI support for AMD/ATI R600
-RADEON_DESC= Include DRI support for AMD/ATI R100
+RADEON_DESC= Include DRI support for AMD/ATI RADEON
SAVAGE_DESC= Include DRI support for S3/Via Savage
SIS_DESC= Include DRI support for SiS 300 and 6326
SWRAST_DESC= Include generic software DRI support
@@ -61,7 +64,9 @@ PLIST_SUB+= ${_d}_DRIVER="@comment "
.endif
.endfor
-.include <bsd.port.pre.mk>
+.if ${ARCH} == "ia64"
+BROKEN= does not install on ia64
+.endif
.if !(${ARCH} == "amd64" || ${ARCH} == "i386")
CONFIGURE_ARGS+=--disable-gallium-intel
@@ -71,4 +76,4 @@ CONFIGURE_ARGS+=--with-dri-drivers="${DRI_DRIVERS:L}"
do-install:
cd ${WRKSRC}/src/mesa; ${GMAKE} install-dri
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>