aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/eog-plugins/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/eog-plugins/Makefile')
-rw-r--r--graphics/eog-plugins/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/graphics/eog-plugins/Makefile b/graphics/eog-plugins/Makefile
index f20682e75089..337a250159ff 100644
--- a/graphics/eog-plugins/Makefile
+++ b/graphics/eog-plugins/Makefile
@@ -63,4 +63,14 @@ post-patch:
${WRKSRC}/configure
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+PYOEXTENSION= pyo
+.else
+PYOEXTENSION= opt-1.pyc
+.endif
+
+PLIST_SUB+= PYOEXTENSION=${PYOEXTENSION}
+
+.include <bsd.port.post.mk>