aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/eog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/eog/Makefile')
-rw-r--r--graphics/eog/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/graphics/eog/Makefile b/graphics/eog/Makefile
index f1ff2b2702f5..75a3ba5ecf3e 100644
--- a/graphics/eog/Makefile
+++ b/graphics/eog/Makefile
@@ -3,13 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/graphics/eog/Makefile,v 1.9 2005/10/04 03:00:35 ahze Exp $
#
PORTNAME= eog
-PORTVERSION= 2.10.2
+PORTVERSION= 2.12.1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.10
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.12
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -22,7 +23,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprintui \
librsvg2 desktopfileutils libgnomeui
USE_X_PREFIX= yes
INSTALLS_OMF= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
@@ -30,6 +31,10 @@ GCONF_SCHEMAS= eog.schemas
.include <bsd.port.pre.mk>
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
+WITH_EXIF= yes
+.endif
+
.if defined(WITH_EXIF) || exists(${LOCALBASE}/lib/libexif.so.12)
LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
.endif